This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Forerunner 955 - Bugs and issues

I thought it might be nice, or usefull, to have a single topic with confirmed bugs and issues with the forerunner 955 watches. Having the solar myself and noticing at least 2 serious bugs, this is good to know for users and Garmin themselves. Perhaps it can be stickied?

People can comment or mention bugs in the comments, or message me directly, and if confirmed by others (or me) I will update the main post. Preferably with as much info as possible.


Maps and navigation

  • Navigate -> Use map: Impossible to select target location (FW 10.10)

    Trying to use the map to navigate to a target point doesn't work. Most of the times the crossharis needed to select a location aren't visible and long-pressing start (usually needed to select the location) doesn't do anything. There are also no other ways to select a location on the map. Sometimes they DO appear and selecting the location is possible, however actually starting the navigation reboots the watch.

    This seems to happen when the location you select results in multiple options (in my case for example ', , ') if I somehow am able to select a location with no alternative options it does not seem to crash. Crosshairs still appear only the first (few?) times after a reboot.

  • Starting a course directly from the "Navigation" app redirects you to the 'Navigation selection screen' (which  is then a bit hard to get out of)

    When going to the Navigation activity and select a course to follow it seems to load the course but then redirects you to the same selection screen where you get the option to again select a course, point of interest, etc. Pressing back once stays in the navigation screen, you need to press back a few times quickly to exit. When then starting another activity the course selected above IS loaded. Other ways such as selecting a saved location DO work and selecting a course for navigation directly from another activity also works.

  • Some custom maps might crash watch?

    Hard to verify

  • Incorrect/garbled rendering of custom maps

    3rd party OSM based maps seem to render incorrectly, while working on the fenix 7 and FR945 watches.

  • Autozoom - Map toggles between extremely zoomed out view and normal zoom level (when showing turns/changing view?) during navigation

    While using navigation and with map autozoom set to enabled, the map screen switches between a way zoomed out state making it impossible to see context regarding streets, etc and normal view when you switch screens or when an instruction is shown. Again switching screens toggles it back, this actually could be reproduced constently (both during cycling as walking activities). When autozoom is disabled and setting a specific zoom level manually this doesn't happen.

  • Map Zoom level reverts back to default (FW 10.10)

    When zooming in or out of the map the zoom level is not retained, it however reverts back to the default zoom level when going back to the map/different screen. Scrolling/pannign around IS saved/stored.

    Apparently this is by design, and can be fixed by turning of auto-zoom for maps:


  • Swipe from left to right on the map (in order to pan) triggers the menu to open

    When making the swip motion from left to right on the map to pan it will open the menu (and exiting can reset zoom on map if autozoom is set). A workaround is to either swipe slowly, or don't remove your finger from the screen right away but let it rest for just a bit longer before releasing the touch screen (might take some getting used to). Not limited to maps, also in other screens.

    Fixed in 11.12

  • Touch with a map screen in an activity only works when "General Touch" is enabled

    When touch is enabled for an activity but not for general use, touch can not be used on the map-datafield for that specific activity. The map touch funcitonality ONLY works when general touch use is enabled, no matter the specific activity settings

  • Widgets are not touch interactive

    Unlike with other touch devices, trying to use touch to scroll through graphs on widgets does not work.





  • Anyone else having an issue with getting no sound on Bluetooth headsets after starting a run?  My headset will stay connected, but no sound.  I have to disconnect and reconnect to get sounds back.  When I reconnect the headset will announce the backlog of all the notifications I missed as if it was saving them up.  It happens almost every time and I've tested with 2 different headsets.

  • i haven't returned my 955, but with my 945LTE, they gave me the option of putting a credit card hold and sending me a new device and then the hold would be removed/credited after the older unit was returned.

  • After creating a powerbased workout in Activitylog2 and exporting it to a fit file, the FR955 doesn't seem to recognize it after putting it in the New_files folder

  • I encounter the same. The watch starts over and over again, whatever input I try. Any button press, touching the screen, the watch crashes and starts again. After a while everything works normal... or what you would call normal in respect to all the bugs and further issues.

  • Anyone seeing their "optimal" load focus zones stuck at zero, so you're constantly above optimal?

    Worked fine on my old 945 but ever since I switched to the 955 Solar a few weeks ago these zones have been stuck at zero.

    Is this a bug, or a result of having something misconfigured?

  • Anyone seeing their "optimal" load focus zones stuck at zero, so you're constantly above optimal?

    Worked fine on my old 945 but ever since I switched to the 955 Solar a few weeks ago these zones have been stuck at zero.

    Is this a bug, or potentially a result of having something misconfigured?

  • I've seen my ACUTE LOAD value keeping same when I've been sick for a week and training status being also just productive. 

    So something fishy and bugs bugs bugs...

  • It takes a few weeks before the zones in Acute Load start to move.

  • Yet another bug to add to the list: Body Battery Supercharging!

    +142 body battery

  • Here to confirm I also have the crosshair problem preventing me from choosing a destination in maps. Also when I go to points of interests and then cities I get the option to 'spell search' giving a popup on my phone app to type the destination. The watch initially seems to acknowledge and starts searching but it just searches indefinitely. But the most annoying thing is that GPS doesn't even work at all for me. The GPS marker is stuck at my home adress and doesnt move.