This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Forerunner 955 - Bugs and issues

I thought it might be nice, or usefull, to have a single topic with confirmed bugs and issues with the forerunner 955 watches. Having the solar myself and noticing at least 2 serious bugs, this is good to know for users and Garmin themselves. Perhaps it can be stickied?

People can comment or mention bugs in the comments, or message me directly, and if confirmed by others (or me) I will update the main post. Preferably with as much info as possible.


Maps and navigation

  • Navigate -> Use map: Impossible to select target location (FW 10.10)

    Trying to use the map to navigate to a target point doesn't work. Most of the times the crossharis needed to select a location aren't visible and long-pressing start (usually needed to select the location) doesn't do anything. There are also no other ways to select a location on the map. Sometimes they DO appear and selecting the location is possible, however actually starting the navigation reboots the watch.

    This seems to happen when the location you select results in multiple options (in my case for example ', , ') if I somehow am able to select a location with no alternative options it does not seem to crash. Crosshairs still appear only the first (few?) times after a reboot.

  • Starting a course directly from the "Navigation" app redirects you to the 'Navigation selection screen' (which  is then a bit hard to get out of)

    When going to the Navigation activity and select a course to follow it seems to load the course but then redirects you to the same selection screen where you get the option to again select a course, point of interest, etc. Pressing back once stays in the navigation screen, you need to press back a few times quickly to exit. When then starting another activity the course selected above IS loaded. Other ways such as selecting a saved location DO work and selecting a course for navigation directly from another activity also works.

  • Some custom maps might crash watch?

    Hard to verify

  • Incorrect/garbled rendering of custom maps

    3rd party OSM based maps seem to render incorrectly, while working on the fenix 7 and FR945 watches.

  • Autozoom - Map toggles between extremely zoomed out view and normal zoom level (when showing turns/changing view?) during navigation

    While using navigation and with map autozoom set to enabled, the map screen switches between a way zoomed out state making it impossible to see context regarding streets, etc and normal view when you switch screens or when an instruction is shown. Again switching screens toggles it back, this actually could be reproduced constently (both during cycling as walking activities). When autozoom is disabled and setting a specific zoom level manually this doesn't happen.

  • Map Zoom level reverts back to default (FW 10.10)

    When zooming in or out of the map the zoom level is not retained, it however reverts back to the default zoom level when going back to the map/different screen. Scrolling/pannign around IS saved/stored.

    Apparently this is by design, and can be fixed by turning of auto-zoom for maps:


  • Swipe from left to right on the map (in order to pan) triggers the menu to open

    When making the swip motion from left to right on the map to pan it will open the menu (and exiting can reset zoom on map if autozoom is set). A workaround is to either swipe slowly, or don't remove your finger from the screen right away but let it rest for just a bit longer before releasing the touch screen (might take some getting used to). Not limited to maps, also in other screens.

    Fixed in 11.12

  • Touch with a map screen in an activity only works when "General Touch" is enabled

    When touch is enabled for an activity but not for general use, touch can not be used on the map-datafield for that specific activity. The map touch funcitonality ONLY works when general touch use is enabled, no matter the specific activity settings

  • Widgets are not touch interactive

    Unlike with other touch devices, trying to use touch to scroll through graphs on widgets does not work.





  • I was going to report this as a bug too, but then completely accidentally managed to solve it by turning off "Auto Zoom" in the map section of the watch menu. I feel that Garmin should make the default off, since removing the ability to zoom makes the mapping much harder to use.

  • I noticed there are more places (except maps that ive mentioned day ago) when you cant normally slide using touch screen, for example - history (of activities) where sliding by finger "this week" activities etc. changes tab...

  • Another thing. You can not touch move map in activity if you have "general use" touch disabled (but i have touch enabled in activity!). I have it because i dont like touch enabled backlight at evening (but i like buttons and i cant it disable it separetly). 

  • Today my watch screen was completely black. When I pressed buttons to access the menus, it showed the menu just fine but returning back to clock screen, it went black. Re-selecting the watch face fixed the issue.

  • Seems to be bugs with adding certain data fields both on the watch and on connect (I.e. cadence, performance condition, and others) they either don’t appear in the list or cannot be added to a given profile. 

  • Cadence works fine here, what I found out is that it is better to completely remove a layout and re-add everything as datafields (maybe only connectiq ones) seem to sometimes stick even though being removed... 

  • Tried restarting both watch and phone. Didn’t work. Creating a new screen half worked on phone for cadence. The cadence menu appeared but was empty and wouldn’t allow for the field to be added. 

  • Yes, you have to be extremly careful moving the map, otherwise you'll see the menu many, many times.

    On the other hand, moving the map works at least here, when displaying an activity or navigation is used, you can't move the map, wether by the keys nor wirh touch gestures (and my shortcut touch on/off seems to be ignored then as well)

  • Had this also with a selfmade watchface (which did work fine fir yesrs on the FR935), thought about an error in my program.

    For me it happend directly after the morning report (at least this was the moment I've seen it first).

  • Has anyone found a city which gets moved below sea level by zooming?

    When i use the '+' key in maps five or six times, half of the map or (most of the time) even the full screen gets blue which may inficate the sea. Bad luck, the next sea is hundreds of kilometers away. Ayhow, this behaviour can't be seen in all situations, I've see it in navigation with a chance of about 50% when zooming.

    Enabling/disabling maps seemed to help, but this just was a lzcky moment.

    BTW does anyone know what "Worldwide DEM B..." means? Or "Garmin DEM Map"? Or the two identical menu entries "Topo Active Europe..."? Or, again two times "CourseView Medi..."?