This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Speed Sensor 2 pairing issues

I'm unable to pair the new Speed Sensor 2 in Garmin Connect Mobile, tried both Android and iOS phones. However, I was able to pair it on fenix and Edge devices in both BLE and ANT modes. Any help?

  • Same here... at day 1 it worked fine with iPhone 11 Pro Max. Tested on Cyclemeter and Ride with GPS. Then the next day RWGPS showed that it is connected to Speed and cadence, but something wasn’t right, because speed was from GPS. Now I can’t connect it to GC. Every app on my iPhone is seeing those sensors, but no data is transmitted. Speed “O” or from GPS. WTF??? 

  • Same issues with speed and Cadence 2, anyone have an idea if I connect through the ANT+ dongle will it work? Don’t want waste more money and still and have nothing 

  • I don’t know if anyone else has experienced this but my SS2 thinks it’s a cadence sensor. When I connect it to Wahoo it detects SPD-BLE###### but provides cadence, not speed. It’s very weird because I bought this speed sensors, had trouble connecting initially but then it worked for two rides. Now I can’t connect or get speed data. Just cadence. Garmin has been completely useless for any helpful suggestions. 

  • Still unable. Exact issue as to the VDO above. 

    I have tried since I had to pay for the bundle with my head unit (Edge 530) It pairs nicely with the Edge, but not with Connect. I want it to do what it says on the tin. 

  • I'm also having an issue on my iPhone 11 with latest iOS software and app. The "PowerTap" app can see and record from my HR sensor and pedal power meters, but can only see the SS2. It doesn't see the speed/distance. Also, the "Garmin Connect" app can see the SS2 but not connect to it. The SS2 has worked correctly previously with both PowerTap and Garmin Connect.

    The SS2 does attach and record correctly on my iPad, both to PowerTap and Garmin Connect.

  • I called Garmin support and they sent me a replacement. Has been working perfectly since. Only downside was that the replacement took 4 weeks to arrive. 

  • i have the same issue. My SS2 will connect to my 935 watch but not finish pairing in my Garmin Connect on my iphone XR.

    Anyone know a solution?

  • Former Member
    0 Former Member over 3 years ago in reply to Daniel

    please tell me if u solved the problem and how. thanks

  • My issue was that the sensor thought it was a cadence sensor. I told Garmin and they sent me a new one (although it took almost 4 weeks to arrive). Problem solved.

  • Former Member
    0 Former Member over 3 years ago

    Is garmin support reading this forum? It’s unbelievable that after 2 years there are still the same pairing and data transmission issues!

    Iphone 6s ios 14.2

    app Garmin connect

    Speed sensor 2 (gen3 bscm), firmware 2.30.00, #3344735896

    Cadence sensor 2, firmware 2.40.0, #3345688984

    I firstly succeded to pair the ss2 the garmin connect app but no data were transmitted, I did again the pairing procedure following garmin instructions

    but this time “pairing failed” and there is no way to pair it again, no matter what you do:

    - removed the sensor from "my garmin devices" in garmin connect app again

    - removed the sensor from bluetooth devices on ios again

    - rebooted iphone

    - removed the battery from the sensor

    - removed and installed again garmin connect app

    - asked garmin to delete all my data and account

    - created a new garmin account

    how is it possible that after 2 years there are still the same issues and garmin DO NOTHING?