This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Screen Frozen, Not Responding, or Gesture and Touch Do Not Work

i bought a lily a few days ago. as soon as I go to the sun the screen no longer lights up either with the movement of the hand or by typing

beta 4.91 improves the situation a bit. but it is not yet perfect. as soon as I go into the sun the screen goes out. and the watch restarts when I get home. the only improvement is I no longer need to plug in the watch for it to wake up.

  • I have had my Garmin Lily for a couple of weeks now, and potentially it looks like it will be really useful. The "arm-shake" manoeuvre to make the watch face visible is quirky and sometimes requires several "waves", but I can live with that. However, today it has given up responding to swipe gestures. The virtual button at the bottom of the face enables the display of the Activities options, but the swiping action has no effect, so you cannot actually do anything with it.

    It is synchronising with Garmin Connect, and has a reasonably full charge on the battery. It would be nice if you could perform the usual technology trick of "switching it off and on again", but there doesn't seem to be a way of doing that (until, presumably, the battery runs down).Does anyone have any ideas about what is wrong or what can be done to sort it out?

  • Update: I have found that if I connect it to the charger, the problem resolves itself, although it then seems to complain that it needs to re-synch with Garmin Connect (which it should be able to do automatically).

    But this is not a viable solution for the longer term: first of all I am not going to be in a position to have the charger / power source to hand whenever the problem recurs, but more importantly, there is clearly a fault with this watch, so unless this can be resolved with a firmware / software update I shall need a replacement watch at the very least, and if that replacement fails, then a different model altogether (or my money back).

    A pity: my husband has had a Garmin Forerunner for 6 years, now replaced with a more up to date model, and both of those have worked really well.

    Can someone from Garmin please comment on this?

  • Two-day old Lily... Activated walking activity and within 5 minutes watch stopped displaying anything despite repeated tapping and wrist gesturing. Could only see watchface display when an alert or notification arrived. Watch stopped tracking steps, etc. Watch only began working again when I plugged the watch into the charger, despite being 80% charged. No steps from one-hour walk registered on watch or in app.

    Also, wrist gesturing watchface activation feature only seems to work properly just after charging.

    Anybody else experiencing these issues (especially the first one) or is my watch a lemon?

  • Hello! I am sorry to see this is happening on the device. Are you still experiencing this issue? Have you synced with Garmin Express yet to be sure its all up to date?

  • Further to this message, I have connected with the app and the phone is fully charged but for the last two days the watch has failed to respond to the swipe and tap gestures. Please could you suggest the reason for this

  • Just got the Garmin Lily today. Even waving or shaking won’t make it react. Have to tap hard 4-5 times on the screen for anything to happen. It’s on high sensitivity and long duration. 

  • Same here, annoying that watch does not respond to any wrist movement or tap, using whatever (synced) setting change

    also language setting via app is not reflected in my watch( after sync)

  • Same here, annoying that watch does not respond to any wrist movement or tap, using whatever (synced) setting change

    also language setting via app is not reflected in my watch( after sync)

    Hello! could you let me know what your gesture sensitivity settings are in the Garmin Connect app? Are these settings the same as what shows in your watch settings?

  • I'm so sorry you haven't gotten a response to this message! I'm having the same issue that cropped up after my watch ran down to 0 battery then was fully recharged, and stayed on the charger for several hours before I could pick it back up.  I haven't yet tried to plug it back in, but I will try that next!

    For me, the capacitative button is the only thing that is responding. I can tap it to bring up the Activities menu, but I can't select it. No taps register on any screen.

    I've never had much luck with this watch and the raise and turn gesture, but I really can't get it to wake up that way now, mo matter how I shake. Sigh. I hope I don't have to get this replaced already! It's only a couple weeks old.

  • I kid you not within a few minutes of posting this while taking a walk, my watch suddenly started to buzzing as if I were getting several notifications, I looked at it (it did not wake when I lifted it) and tapped and suddenly it was all working. Blah! Good, but frustrating!!