Strava Segments not syncing Edge 1040

I cannot get my Strava starred segments or courses  to sync on my Garmin Edge 1040 Solar.  I upgraded from a 530 to the 1040 Solar (had no issues with 530 and segments) and always see the same "Sign into your Strava account using your Garmin Connect account" via the segments widget. I am signed in and see "segments" widget on my web-based connect dashboard with my starred Strava segments. In the garmin connect app I see that segments are also enabled.  Anyone else have the same problem?

I have tried these things....

1. Disconnected Strava from Garmin and reconnected (on Strava's website) 

2. Disconnected Garmin from Strava and reconnected (via Garmin connect profile) 

3. Added new segments in Strava to hopefully force a sync (unsuccessful ) 

4. Tried syncs with Phone 

5. Tried syncs via Garmin express via USB-C Connector. 

  • Dann antworte ich dir mal auf Deutsch. Ich hab das gleiche Problem gehabt. Leider hat nur ein Reset was gebracht. Die Sensoren wurden nach dem Reset übernommen. Musste also wenig wieder einstellen. Jetzt werden mir die Segmente angezeigt. Trotzdem finde ich das mit den Segmenten bei Garmin etwas umständlich. Muss sagen das es Wahoo da besser gelöst hat.

  • Reset hatte ich schon 2x gemacht, mittlerweile hab ich Übung darin. hat aber NICHTS geholfen. nur der Segment Explorer hatte dann mal funktioniert. Aktuell (seit heute morgen / ohne dass ich was geändert hatte) geht selbst das nicht mehr... sonst bin ich mit dem 1040 eigentlich zufrieden. Aber die Strava Integration ist derzeit Mist.

  • Da geb ich dir Recht. Auch das die Segmente während einer Navigation oder Training nicht angezeigt werden wenn du eins abfährst. Ansonsten bin ich auch zufrieden. Hast du das Update von Gestern aufgespielt? 

    Ich fass nochmal zusammen:

    - Strava Konto und Connect Konto verbunden?

    - Berechtigungen erteilt?

    - Segmente Favorisiert? 

    - Strava Segmente auf Connect Dashboard platziert und sind auch zu sehen?

    - Strava Segmente werden auf dem 1040 (Widget) angezeigt?

    - Strava Segmente sind unter Training alle aktiviert?

  • bis auf die letzten 2.... ja / und die 12.15 ist schon seit Beta drauf

    das widget ging bis gestern...nach dem löschen und Rückseiten (auch nur via bluetooth / nicht via WIFI)

    unter training kann ich keine Strava Segmente aktivieren, da keine angezeigt werden.

    (hatte gerade mal Garmin Segmente drauf, diese konnte ich problemlos aktivieren)

    mache gerade den 3ten Reset :-(

  • I'm having an issue with Edge 1040 Solar and Strava segments as well. The very first ride worked just fine and I was able to see Strava segment PRs/achievements (interestingly enough, the data recording setting was set to the default "Smart" value). But then it broke (I'm not 100% sure, but I think there was a firmware update after the first ride, so maybe that's what broke it): I do see favorite Strava segments listed in the Garmin Connect Android mobile app, but the ride segments aren't being synced to Strava and it shows the "No Segments on this Activity" message instead. After reading Strava help materials, I tried changing data recording setting to "1 second" to make sure I get more accurate results, but it didn't help, so the culprit of the issue must be something else. I made a couple of good effort rides recently and it's really annoying that the segment stats were lost. I never had that issue with my Garmin Forerunner 935 watch in the past, which makes it even more frustrating that the brand new Garmin Edge device isn't working properly and I hope this will be fixed ASAP.

  • I have the same issue. And do not have the guts to reset and reconnect. There must be a better solution. @Garmin: please help

  • To be clear, I DO see the actual segments on both the Gamin Connect Android mobile app (using Strava segments widget) and on the Garmin Edge 1040 Solar itself (on the Training -> Strava Live Segments view). The problem for me is that no segments are listed on the Strava activity page after the ride is over and synced from Edge to Strava.

    The activity page on Strava shows "No Segments on this Activity" message only:

    I actually tried clicking on the "Don't see the segment you're looking for?" link to search for a particular segment I know I completed on that ride and what I found is that it seems to be some sort of a weird segment matching issue:

    Note how the gray (your activity) and the red (selected segment) are very close, but not exactly the same in terms of GPS track. Could this issue be caused by the improved GPS accuracy of the Edge 1040 (I do have the "Best Accuracy" option selected for the GPS setting)? Is that more of a Strava than Garmin issue then?

    P.S. I now also realize that the issue I'm having might be different from the issue originally reported in this thread.

  • Just FYI: I submitted a request on Strava as well to see if this might be an issue on their end.

  • finally i was able to fix my issue with the help of Strava support. there was a glitch with my user/membership... after i did a "restore purchases" on my iPhone (Strava app) the segments worked again. Strange because some other pieces of strava which require membership, did work before i did"restore purchase" .... anyhow, many thanks for all the hints an tips here.

  • I have the same problem. The widget screen is telling me to sign into Strava but I’m already signed in. I can check my individual profiles and see the segments there but the widget screen doesn’t appear to be synchronising.