This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Speed Sensor 2 pairing issues

I'm unable to pair the new Speed Sensor 2 in Garmin Connect Mobile, tried both Android and iOS phones. However, I was able to pair it on fenix and Edge devices in both BLE and ANT modes. Any help?

  • As with many on this thread, I am having the same problem (I have SS2 and CS2 bundle, trying to connect to iphone8, with connect app updated today). My SS2 connected at first, but has not connected since. I’ve tried everything suggested below but no success. Thanks. 

  • At this point it seems clear to me that lot of people spent money for sensors that are useless for purposes they bought and that Garmin support is not able to give any solutions to solve the problem.

    This is unacceptable !!

    Garmin , if you’re there, hit it !

  • I still can’t pair this sensor. Honestly not impressed and will return this is a solution isn’t provided. 

  • Can’t pair it with garmin connect. It was connected but then I remove it because it was not recognized in zwift. I t was paired in any mode to a Fénix. 5. I removed the battery. Removed from the list of ble device in iOS. Remove it in fénix sensor. I still can’t pair it to garmin connect. I’m always with some Bluetooth devices around in my house or work. Don’t know if this can be an issue


  • I had the same issue as everyone here iPad Air 2 and iPhone 7plus, however it continued to work on my wife’s MacBook Air. I ran the sensors on zwift and the speed stopped working suddenly. Today it started working and this is what I did if it helps anyone. I had zwift running on the MacBook with both sensors connected so they were “transmitting” and then tried to pair on garmin connect on the iPad. To my amazement the speed sensor suddenly paired and finished setup as if nothing had ever been wrong. I then closed zwift on the MacBook and opened it on the iPad and surprise surprise it connected instantly and I’ve just done a 60km ride without problems. No idea if what I did helped or not, I’ve tried everything, reinstalling apps, disconnecting Bluetooth, turning off every BT device in the house, I’ve emailed everyone under the sun and nearly threw the damm thing out the window. I hope this helps some of you, I feel your pain and frustration. Cheers 

  • ***UPDATE***


    1. I have put new batteries on each sensors ; Speed and cadence. 

    2. Try to the sensors into my Garmin forerunner 35 watch.

    3. I placed the watch really close to one of the sensors (4cm).

    4. instantly the watch and the sensor got paired.

    5. Done the same with the other one.

    6. Sensors paired successfully.

    7. Started a new cycling activity on the Garmin 35.

    8. Go to Options.  Change from outside cycling to inside cycling (it disable GPS. I'm using a bike with home trainer)

    9. Start the chrono and pedal.

    10. Finished my workout. Stoped the watch and sync the phone with the Garmin forrunnner 35.

    11. The workout with all datas appear !

    It probably means the pairing issues don't come from the sensors but probably from the app.



  • Having lots of issues with two sensors - both keep dropping out on Zwift (which I initially thought was the problem as it all really started at the same time as a Zwift update) but now neither will pair with Connect.

    Getting a red/green flash during riding. Both units will pair with my Edge 130 by ANT+ and BLE. I think they’re on firmware 2.3. This is all really annoying.

  • Yep here too, and Garmin dual band HRM. Cadence and HRM work fine, Speed Sensors flaky.

  • This is frustrating. I don't know what the real issue is? I bought these sensor because of watch compatibility (Garmin Instinct). the bluetooth functionality wont pair with my watch, only the Ant+. Zwift won't pair. Garmin Connect won't pair. Macbook won't pair. Bought new batteries, still won't pair. Shut down all bluetooth interference scenarios. Still won"t pair. 

    Then i thought my unit was busted. Brought it to the store where i bought it. Have it replaced brand new. Tested it before i went back home.  Paired it with my Instinct and the stores Fenix 5. Bluetooth and Ant+ are ok. But when as soon as i got home. The same  problem is still there. Whose to blame here?! Garmin, Apple or ZWIFT? Im gonna ditch this thing and shift to Wahoo if Garmin won't give any legit answer. So frustrating man!

  • I believe it wasn't.

    The problem still exists with the latest GarminConnect on IOS (IPhone 8).

    The sensor paired fine the first time around reported data, everything fine. Zwift worked too on IOS, Mac and Windows.

    Then the sensor stopped connecting to GarminConnect. Removing and re-pairing it brings up the sensor-found-but-could-not-connect issue. The sensor still works fine with zwift on IOS and, Windows and Mac . It pairs fine with the IPhone. Just GarminConnect does not connect to it.

    I re-installed GarminConnect, but to no avail.