Ticket Created

WERETECH-7952

Semicolon Problem in Pace Settings

The settings won’t let me put a semicolon between the minutes and the seconds for the pace setter.

  • I use a string parameter to capture email address for registration verification.  Initially I configured the settings file as type=email.  After having lots of issues with users getting crashes after saving the settings depending on which app was used, j switched the settings file to type=alphanumeric.  I trialed it with a beta build and everything worked fine.  The day I roll out the change to my widget, the previous build of the CIQ app store was released which prevented the ability to use (.), (@), and (-) characters in the string.  GCM still works fine.  In my case besides not working on the CIQ app store complaints, I have had much lower reports of the widget crashing after applying the settings when using alphanumeric vs email type.

    Besides this bug there are a few other anomalies with setting that I have yet to figure out.  Behaviors can very depending on what tool is used with differences on how the data is validated based on the settings type.  Once I can find a pattern, I will open another bug report.

  • all special characters are disallowed in the connect iq app, so this includes minus (-), dot (.), slash (/) and colon (:)....  

  • This needs to be fixed ASAP. I have a race in a few hours and the workaround by peterdedecker saved me. 

  • I can confirm the bug exists, and the workaround over Garmin Connect Mobile app helps out for now!

  • The same issue is also present in the android version of the connect iq app, the same workaround can be used.