I don't understand the naming convention: button_left_middle? Why? Aren't we encouraged to use BehaviorDelegate instead of InputDelegate, the left_middle makes no sense at all for onMenu. Not that it would make much more sense if I used InputDelegate... Am I supposed to manually map each device's each button between the personality position and the behavior? This seems to be not very feasible.
Also: I don't use layouts, I draw on Dc. Any way to use the hints? The best would be if there was a way to get the button positions so I can draw my hints as icons.