This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Blank screen when signing in to Garmin account

I have a new laptop (Windows 10 Pro), and have installed the latest Garmin Express version. It recognizes my Fenix 6 Pro without problems, but when I click 'Sign in' in the next configuration step, a blank window opens, just stating 'Garmin Connect'. It keeps blank, even after waiting 30 minutes. Nothing seems to happen.

I have uninstalled Garmin Express, reinstalled it, and rebooted my laptop between every step. No luck. Installed and run as Administrator, nothing works.

What is blocking this login screen? Does anyone recognize this?

  • Same here... drove me 3 days crazy - especially since it worked on another notebook (old Lenovo w/ Win10) without any issues. By the way: i tried it with version 7.5.0.

    First Garmin Watch (Vivoactive), but i didn't considered level 1 SW-issues when it comes to log-in prompts... :( :( :(

  • I am glad I found this thread. I was getting very frustrated. It is good to know that Garmin has been aware of this problem for six months and still hasn't decided to fix it. I a planning on upgrading my watch this summer and will likely go with another manufacturer.

  • I have a new Laptop 4 and have this problem The screenshots above are the same as what I'm getting. Re-installed GE, but no good.

    Switched off VPN (Express) & Firewall (Norton), but to no effect. Typing in irrespective of no fields did not work for my configuration.

    This is obviously a serious problem with Express. One can only assume that they are not watching the Forum, as I installed 7.5.0 which is new and still no resolution.

  • Typically Garmin staff doesn't read this section of the forum. Usually the hardware/device forums. I only see 1 person on this thread ,  that has called support. I would do it, but I'm not experiencing this issue and cannot give them the applicable log files they are going to request. Meanwhile, I'll reach out to see if we can get an update for you here.

  • Hey, I had the same issue and your resolution worked for me. I hit Ctrl-Alt-Del and the login screen appeared. It seemed as if nothing was happening when I tried to type my email and password, but thanks to what you posted, I typed in my email, then hit Tab and entered my password and it worked. I only lost 3 hours and luckily, I only have one device. Thanks for your post. Too bad a company like Garmin can keep churning out new devices, but their computer software is such crap. Has so many issues over 4 years.

  • I have email this problem to Express Support.

    I suggest everyone does the same, otherwise this will never be fixed.

  • I've found a solution to this after days of pulling my hair out.  I know that the post is 6 months old, but I will post it here in case someone else comes looking for it more recently.  It seems that for me the issue was related to the Intel Iris XE graphics driver.  If I open up device manager and expand the display adapters section then disable Intel Iris Xe Graphics, it works just fine.  Not sure how to go about resolving this on the mac, but it could be related to the same display driver.  Garmin, get on it!

  • Yes well done! This work-around is the answer to the immediate problem of logging in.

    Note that disabling this display driver just gives you another one, so it's not an issue. The login fields were then available, but login just circled. This is a problem with ExpressVPN, so I had to disconnect that as well. Then all was ok.

    I re-enabled the display driver and also connected my VPN again and GE worked ok as it is now downloading this years Maps.

    So "9132360", well done again, your effort much appreciated! As you say, Garmin needs to fix GE for these new drivers.

  • As the majority I have bought a new laptop and the sign in on Garmin express was not possible, thank god I found this thread.

    It is very frustrating not to be able to login and a huge mistake by Garmin how they can not fix it since 6 months is simply not understandable!!

    Thank you to the fellow member who found the ghost login protocol.

  • Same issue on my Windows 10 laptop. Your suggestion helped me solve the issue. Thanks a lot