This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Scale Does Not Synch Additional Users


So my scale worked perfectly, but I was having an issue with Garmin connect connecting to Apple Health so I reset the app an in the process managed to unpair my scale. Since resetting the app it will sync a second user. To clarify I can setup the scape and sees the owner, but anyone else that is invited is not. I have tried setting it up on my device and inviting my wife, the scale only see me. So I reset it and setup using my wife's phone, then then it only works for her.

Each time we send the invites, setup the accounts, the guest shows up as a user in the app but does not appear on the scale.

Please help?

  • Garmin customer service aren’t being very helpful with this. They ask us to delete all users then re-add which both users have done at least twice. We’ve followed the advice from Garmin that you should leave the scales in sleep mode for 2 days for them to sync but… nothing. 

    feeling very much ignored by Garmin. 

  • I have the same problem. Waiting for a reply from Garmin Team.

  • It is doing the same for me as well. I had to remove the app from my phone and reinstall it, w caused me to have to add the scale again. Somehow it wiped the other users. I have tried several times to add them but nothing shows soon the scale. In Garmin Connect, the scale shows, but it says firmware version 0.00 while my account says 3.20. Garmin needs to fix this.

  • Its the same for me. Have been using the scale as the primary user for years without issue, but when I added my wife, she does not appear on the scales. Have reset scales 3 times. Reset and reloaded scales. turned off both iPhone's. finally got mine to reconnect. Invited my wife for the third time, had to remove her from Garmin Connect 3 times. Finally got both iPhone's Index Smart Scale connected via Garmin App, but only my user name appears on scales still. Changed her weight to try and recalibrate but no go either. very annoying  

    Was going to upgrade to Index S2 but after reading the bad reviews, i've canned that idea.  

  • Agreed. Got a different brand of scale now. Also it seems more accurate at all body composition than the Index ever was. We got Renpho. 

  • Looks like Garmin fixed the issue. It works fine now. I didn't do anything. Yesterday additional user suddenly popped-up on Index Smart scale display...

  • Yes, mine too. Although it does say settings that my scale is not completely setup. However it's working for all users and I reluctant to mess with it further.