This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Scale Does Not Synch Additional Users


So my scale worked perfectly, but I was having an issue with Garmin connect connecting to Apple Health so I reset the app an in the process managed to unpair my scale. Since resetting the app it will sync a second user. To clarify I can setup the scape and sees the owner, but anyone else that is invited is not. I have tried setting it up on my device and inviting my wife, the scale only see me. So I reset it and setup using my wife's phone, then then it only works for her.

Each time we send the invites, setup the accounts, the guest shows up as a user in the app but does not appear on the scale.

Please help?

  • I had the same issue and after a while it did appear. 

  • We are having the same issue.  Any update?

  • We are having the same issue

  • I have similar problem.

    I am the master user and have invited my wife. Worked fine for a few months. Now it stopped work for me and I deleted the scale and made a reset of everything. Paired the scale with my master account & phone, and invited my wife again.

    She has accepted. But it does not work. At her phone the scale looked connected in Garmin Connect, but it also has a line under which says that another device already exists in her account..?

    I have logged in to her account on a computer and tried to delete the scale from her account, sent an invite again.. but no.

    I have the feeling that my wife’s phone still has paired by Bluetooth with the scale from the first time, and it looks impossible to remove the pairing on iPhone…?

    This scale is NOT user friendly in the setup!

  • Sadly the same. Was working fine then had to reset it as we changed wifi. No, no matter what we do the prime user appears fine (once we discovered that in order to enter your user details you must hit "return" after adding user initials!) but any subordinate user does not appear on the scale (though they show on the prime user's profile and the subordinate user's Connect sees the scale. Garmin... make your user interface and setup less clunky!

  • Same issue here. I changed phones, managed to remove everyone from the scales. Hubby synched it to his phone as primary person, his name comes up fine. Invited me and our daughter, accepted, all good. But we don't come up on the scales. I've checked and both additional users have allowed data upload (saw that on another thread). This is frustrating. 

  • I have exactly the same issue. Scale shows only master user and guest. Invited user properly accepted invitation and is shown as user in Garmin connect web and iphone app. Several re-installations from scratch did not help. 

  • Identical situation for me also

  • I had the same issue. firmware 3.20 No additional user name on the scale after confirm invitation.

  • Same issue here! Actually, for some reason the scale did not let me set it up again (kept the bluetooth connection with my iPhone) and I solved it by setting it up with a different account and then again set it up with my main account. But as well, I invited my wife and my son and they both accepted and everything seems to be ok (both have the scale available under their devices) and I can see them as accepted users on my app and garmin connect website but only my name appears on the scale... this is frustrating, it used to work I guess on a previous software version... mine is also on 3.20 Disappointed