This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Scale not syncing

Why is it that every time Garmin Connect gets updated, there is a problem with the scale? As of today, I get >>>>>>>>>>x 

Is there something the users can do to solve this, or is Garmin going to fix it anytime soon? It is quite frustrating to see a 'smart' scale operating in a way that is not smart :)

  • Mine refuses to connect no matter what I do.  I've set my DNS to and, rest router, reset the scale. Deleted it from Garmin Connect and readded it.  I'm about to throw it through the wall it's so frustrating.  Normally I can get it to connect it to my router when it's being finicky by moving it near it, but today it's sitting right next to the router and it won't do anything.

  • I understand, I did all this too but still no luck. But I have noticed these issues appear right after a Garmin Connect update. I go to Garmin Express and it shows there is an update available for the scale and that it will be delivered next time the scale syncs, only that it just won't sync 

  • I can't find my darn ANT stick either, otherwise I'd try connecting it to my computer through that.

  • I don't have an ANT stick. I just connect my watch to my Mac with the cable and open Garmin Express. When I go to the scale icon, I get a notification that there is an update available. I just don't know how this update can be delivered to the scale, since the scale refuses to sync.

  • If it's an iPhone that you use, go to the GC app and find the scale in your devices. Tap on the scale and then scale settings and wifi networks. Push the button under the scale and wait. Once you see the tick symbol next to your wifi network on the phone screen, tap on the back button and you should see the tick on the scale screen too. See if that works. I did it here and it worked, but only for one time Smiley I am just curious to see what your scale will do.

  • I use android.  I've tried something like that a few times and can't seem to get it to work.  I've found my ANT stick and added it to Garmin Express on my computer.  The thing where it says it needs to update seems to have gone away now, but it's on the same firmware that it was on before.  Running 3.10.

  • Yeah, that's the version I have too, The notification went away here too, I don't know how, but I tried it 2-3 times and it seems to work now. 

  • Still the X here.  

  • Here now too. I don't know what to say, it worked a couple of times and now back to the same again Disappointed

  • ..and the update sign appeared again