This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Index Scale no longer connects

Has anyone fixed this yet?

I‘m unable to connect to WiFi. 
Tried all the suggested fixes splitting the WiFi signal, using the stick, using hotspot, resetting etc. 

Something clearly happened a couple of weeks ago. 

Come on Garmin the forum is littered with dozens of similar posts. 

  • Thank you! This worked for me! I’m still annoyed with them, but very grateful for this solution.

  • this worked for me.

  • Work on and off. Today syncing and tomorrow maybe not syncing. It seems working like Garmin, not always know where to go. Hello to Garmin team! ;) 

  • Many thanks, AMChorlton!  It worked for me!  I wasn't confident to reset my scale because when I had this similar issue months ago, it took me hours to setup again because the index was not connecting to my wi-fi network.  However, I decided to try the procedure you suggested and I am very happy it is back to life and to communication again!

  • Over in another thread, someone reported connection was "time of day." That's been my experience, as well.

    I weigh myself in the morning, and there's an "X" for failing to connect. Yesterday, it worked at ~15:00, and today at ~13:30 in Mountain Standard time (GMT-7).  I'm pretty sure there's something in the Garmin server that is time-sensitive through the day - though it may be fixed by the time people here try it again.

    I've taken to weighing myself at the normal time, then a second time in the afternoon and deleting that entry.

  • I've been having connectivity issues with my Index Scale for the past month.  I've had the scale just over a year, and have had no problems up until now.  I haven't made any changes to my network.

    I contacted Garmin Support, and they sent me out a new scale - didn't even want the old one back.  The new one worked for set up, and then synced for about 2 days.  Then it stopped working again.  Same issue - WiFi icon blinks, but no arrows, no "X" and no data in Garmin Connect.

    I did some searching and found some people talking about issues using for DNS, which i do in fact use. I set up a new network and used instead and just like that it started working again.  We'll see if it lasts, but it seems clear to me that the old scale works just fine, that this is a connectivity issue and that it didn't need to be replaced.

    Seems like Garmin Support should read their forums before sending out new scales unnecessarily.  I hear they've recently had a big expense...

  • I am experiencing the very same issue! Can you please tell me how you made it work again? It is so frustrating to see this scale disconnect from my WiFi all the time Disappointed

  • I'm not sure you are having the same problem that I was having.  For me, the scale was connecting to Wi-Fi, but it was not uploading data to Garmin Connect.

    My experience was, I would step on the scale and it would get my weight.  Then, my name would blink three times and start to display the stats.  During this time, The Wi-Fi icon would be on, with the top line of the icon blinking.  It would display my stats, but I would not get the arrows streaming across the top.

    I could see on my router that the scale was connected to my network.  However, now arrows and no data on Garmin Connect.

    Are you able to tell if your scale is connected to your Wi-Fi network?  Do you see an "X" in the upper right corner after stepping on the scale?

  • In the end I deleted and reinstalled the app, reset the scales and reconnected them, and changed DNS to, and that combination of things worked. In my case it was after the app reinstallation that I was finally able to get it to work properly, but different people seem to be facing different issues. Deleting and reinstalling everything and changing your DNS should work, but obviously I’m not a garmin expert so I can’t guarantee anything.

  • They don't. I've had the problem over a year with my useless scale. One morning randomly it stopped working (I suspect a software update was pushed out or a Garmin server setting changed). I wasted hours and hours trying to troubleshoot only to come to the conclusion that it was something on Garmin's side preventing me from connecting my scale. The only time they respond is to remove unfavorable comments (like this one). I feel tricked by fancy marketing.  Their indifference and lack of product support has lost my business forever.