This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Index Scale no longer connects

Has anyone fixed this yet?

I‘m unable to connect to WiFi. 
Tried all the suggested fixes splitting the WiFi signal, using the stick, using hotspot, resetting etc. 

Something clearly happened a couple of weeks ago. 

Come on Garmin the forum is littered with dozens of similar posts. 

  • Same here. This is what I get every time I get on the scale >>>>>>>>>>x but all worked fine until this morning. What I have noticed is that such kind of problems appear every time there is a software update of Garmin Connect. I really don't know how to fix this, I have tried almost everything, reset, remove the scale from my account and pair it back again, nothing seems to work so far

  • Same here since last thursday, setup works, add user works, it looks like it sends my weight, but nothing arives
    Reset, new batteries, removed from garmin, nothing helps

  • Same. Won't connect to wifi, gets an X.

    Will reach out to support this morning.
    Sounds like it's no longer an isolated problem?

  • Sounds like it’s a few of us then, so I’m guessing the problem is with Garmin. It’s really poor that this is a recurring issue given that this stuff is Garmin’s USP and entire business model. I’ve been with them for most of a decade but if they don’t get their act together soon I’ll be looking elsewhere in future.

  • It appears to me that after each upgrade of a new version of Garmin Express on my PC the Smart Scale loses the Wi-Fi account information.

    My Wi-Fi network already exists and was used previously with the Smart Scale. The Smart Scale already exists in Garmin Express on my PC. The Info tab and Utilities tabs for the Smart Scale do not show me my Wi-fi network exists, there is no edit button. The "Find Networks" button is grayed out and non functional. Only way  to get a prompt to type in Wi-fi account info is to go through the Add Device steps which includes using the Reset button on the back of the Scale. This worked previously to get my uploads started again but now after this Garmin Express software upgrade the Wi-fi info is not being retained at all. Next use of scale fails to upload data. This last upgrade on my PC was to Garmin Express Version

  • Last Thursday my scale synchronized for the last time.  Since Friday it shows the ">>>>>>>>>> X" and no data is uploaded.  I am using DNS  It is unbelievable that such issues happen with Garmin products.  Isn't there a test before releasing any update in their software?  Garmin watches are the best for runners, but every time such kind of issue happens (this is not the first time for me), I wonder if I could move to Apple Watch.  It is always evolving, new features, and simply works!  Garmin, please fix this!

  • The notice on my Garmin Connect tab says there's a software update for the scale, dated June 26. I started having problems on June 27. Today (June 28), it's not connecting at all. Once the software is loaded into the scale, if there's no wifi connection, there's no way to fix it.

  • I get nothing now as well. It won’t even connect to my smart phone, just hangs on the Bluetooth symbol and wrench. 

    tried a million resets, have a BT home hub and no clue how to change the DNS on there, but suspect that isn’t going to help. 

    come on Garmin! 

  • All I can think is let’s all keep on their case and hope they value their customer base at least a little.

  • I’ve gotten mine to work. 

    Batteries out. Press and hold reset for a minute. Delete Garmin Connect App on phone. Reinstall app. Press reset button to start pairing. Open Garmin Connect follow prompts as instructed. Straight in.