This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

WiFi and Connection issues for the Tech Dummy

My scale does not connect to WiFi and does not send data to GC. It did seamlessly a few months ago, but then all of a sudden it pretty much stopped working and hasn't worked since.

So much chatter on this forum of what is causing the problem and some viable solutions.

The problem is, I am not tech savvy and I do not understand most of the chatter that is going on.

What I would like is:
- Garmin can fix this problem on their side so that ALL USERS will not have this problem anymore.
- send out a STEP by STEP set of instructions that a dummy can understand on how to set your router or what I need to do to fix the problem.

  • Hi,
    if there might be connection issues, the first thing I do: check, that the signal from the router/wifi-extender is strong enough at the place of the scale. For my iPhone I use the app CloudCheck. Here I can see how strong the signal to the router is.
  • My scales have been working seamlessly for 3-4 years & Encountered this issue when upgrading my home router. Similar sort of issues I’m facing & no answers, great :S 

  • Thank you, first solution worked out great! It’s connected to my WiFi again, reversing polarity shows the firmware on the first screen, it doesn’t show with the reset button.  3.10 firmware

  • How did this go. My scale just started doing this today.

  • Garmin once had a Thread in this Forum with the NTP Server Things. I still think they knew whats wrong but never were able to deliver us a functional product. They should send us all a new Scale in my Opinion because thier first product didnt Held what they advertised.

  • I have this issue too. I've had this scale for years (working without issue) and it stopped connecting to WiFi in November. Nothing I've tried has worked. I tried the DNSMasq suggestion from someone's post but it accomplished nothing. I'm running a router with Tomato on it and when I added the DNSMasq, it didn't change the IP that was searching for. I'm sure I did somethign wrong there, but I can't figure out what.

    Anyone have any help on this?

  • Hi, this might actually help if your wifi cannot be seen at all by the Garmin Index S2 Scale, even if you put it next to your Wifi AP / Router: I realized that the scale only sees / understands the US Wifi channels (1-11) and as long as yours manually or automatically is set to a European / Asian Channel, then it will not be seen. These are Channel 12 and 13.
    Make sure your Wifi Channel is withing the US range and try again!

  • My Garmin Scale has suffered the same problem now for one year, nothing seems to solve the problem. I really hope that Garmin could help with this problem!

  • This worked well for me. Complete re-setup.


    Please definitely try the option of using a hotspot on your phone.  please make the hotspot configuration = simple and quick to implement.

    example temporary config:

    SSID = Guest

    enable SSID broadcast

    Wifi security = WPA2

    Password = password123

    (note: you can reset your phones hotspot as complex as you want after the issue is resolved)

    Now turn on your phones hotspot, open Garmin Connect on your phone, access Garmin devices, select Index Smart Scale, select Device Settings, select Wi-Fi Networks.

    you should see l your phones hotspot listed, select it and enter the password you used.  once you have the green check mark you merely need to back out of that configuration page to the main Garmin Connect dashboard.

    watch the screen on your scalp and it should quickly cycle to a check mark and then return to standby.

    now that it has a successful wifi to your temporary hotspot configuration your can change the wifi settings again to your home's wifi and this time it should work.

    I'll say this was a very frustrating time for me and I considered replacing it, but I'm glad to say I resolved my issue with the process outlined above~


    Anyway, this reference to adjusting clocks is really a potential workaround for several.

    Any of you may have an issue depending on your firewall ruleset; if by chance you block traffic at your FW for anything destined to Singapore your Garmin Index Scale will NOT connect to WiFi completely.  The Garmin Connect app will state it has completed the setup of your device; when you back out of the WiFi settings menu to the Garmin Connect dashboard your Garmin Index Scale will flash the WiFi icon and the wrench icon will remain constant.

    I merely unblocked traffic to Singapore in my router and this resolved my issue.