This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

SETUP ISSUE: Scale can pair, but timeout at connect to WiFi -- Kludge fix

I found setup of the Garmin scale to be a nightmare. I had no problem pairing the scale, but then the scale would timeout rather than connect to my home WiFi, so I could not complete the setup process.

Tech support was very patient and we tried: (1) an iOS phone; (2) an Android phone; (3) a Win 7 computer; and (4) a Win 10 computer. I have two different WiFi networks bridged together and it was the same for both routers. Finally, we tried removing the password from the router and that permitted me to complete setup.

Since the scale is now happily on my WiFi network, I probably can add the password back to the router, but would then have to disable the password again each time the scale needs to login to the network (e.g. after battery change or if the router lost power). Since that’s such a rare occurrence, this is not the worst kludge.

Just a head’s up in case anyone else runs into this and wants to save two hours on the phone with tech support!
  • Fixed

    This seems to be the behaviour I am experiencing as well. From the reading I have done it appears to be an issue with GC profile syncing. I tried to call Garmin support on the 24th but they were off for the holiday's (must be nice!). I am going to call again when I get back in to town. My thought would be to delete it from your GC profile and try re-pairing again. I have also read about myfitnesspal causing issues (I.e. GC profile getting weight from MFP) - I will let you know what I find when I get the chance to troubleshoot.

    Well I got home last night and have fixed my issue. I went in to MyFitnessPal and removed the GC app link. It appears that GC was getting all weight data from MFP and stopping the index scale from getting data in. I am not sure what to do about the link between MFP and GC now - I suppose another round of testing is in order! But at least I know this is not a Index issue - it is a integration issue between MFP and GC
  • Replacement coming --- I hope it works!

    After over two hours on the phone yesterday with tech support Garmin have given me an RMA for my scale. They had me basically redo all of the solutions recommended here. I hope the replacement works after all of this!
  • Similar Setup Issues

    I have also spent way too much time and effort into setting this scale up with no success.

    1. Have "successfully" set up the wireless using all three methods on multiple accounts (wifi, Bluetooth, and ANT+).
    2. Tried two different wifi routers with security, no security, all other suggestions to no avail
    3. Have conducted multiple factory resets to just give it "one more try."
    4. Looked at the" Wrench of Death" for three days hoping some magic would happen.
    5. Contacted Garmin support through website and waiting for their reply.
    6. Decided it was the scale and ordered a replacement unit through Amazon.
    7. Excited when replacement unit actually gave me two circular arrows and >>>>> across the top before breaking my heart with >>>>>>>>X
    8. Repeated steps 1-5.
    9. Read possible issue with MyFitnessPal, deleted all accounts that sync any data with Garmin Connect (mFP, Strava, Apple Health and repeated steps 1-5 while quietly weeping in the corner.
    10. Created a "Ghost Account" on Garmin Connect and only attempted to link the Index Scale in hopes that there was some other setting that I have toggled over the last five years and still got >>>>>>>X and that stupid wrench.
    11. Wife and kids decided they needed some space as I'm spending too much time with a scale - I'll just rock myself to sleep in the corner with that wrench burning through my retina.

    Please help.
  • Social Media

    I have also taken to Social media (Twitter and Facebook) to see what chains can be rattled. Will keep this thread informed with any updates.
  • I had the same issue people are describing with WiFi setup not working. Suspecting it had something to do with the WiFi authentication, I changed the authentication method on my router from (mixed) WPA2/WPA Personal to (only) WPA2 Personal, and it worked. Hopefully this will save people some headaches and Garmin will investigate this issue.
  • Finally!

    I went back and forth with Garmin support via email (calling was impossible) and they offered an exchange. Got the replacement yesterday and it set up in less than 5 minutes right out of the box and is working great. The software version on the scale is the same as the one I returned and nothing has changed with my WiFi network. I suspect some of us had units from a bad batch. In the end I'm happy with Garmin's support.
  • Finally the insanity stopped!

    Tim at Garmin support finally was able to put an end to my problems after three different scales and multiple troubleshooting issues. They quickly responded to my facebook messages and was very happy with their ability to stay engaged and work through the process. If you are still having issues email them at [email][email protected][/email], I would get responses in less than 24 hours.

    For me what it boiled down to was a security setting not on my wifi router, but on my XFINTY gateway and I believe it was blocking a port. You can see the security settings - the more secure blocked whichever port the Garmin Scale needs to connect to the server. I was always having good internet connectivity...but this one setting caused me 30 days of grief. Hope it helps!
  • Former Member
    0 Former Member over 8 years ago
    Does anyone know what port the scale is using?
  • The WiFi Index issue is killing me.

    I tried everything posted here - I made it work for 2 day but now it refuses to connect to the WiFi.

    My bet is that the Index is using the cheapest wireless network adapter. I never had so much problems with a device :(
  • I finally figured out my problem and it was my security settings. I set up my WiFi to allow only the MAC addresses of personal devices and computers. Since I cannot find a MAC address for the scale, my only option was to turn the security settings off, weigh myself, wait for the upload, and then turn security on again. It's a pain but it works.