This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

SETUP ISSUE: Scale can pair, but timeout at connect to WiFi -- Kludge fix

I found setup of the Garmin scale to be a nightmare. I had no problem pairing the scale, but then the scale would timeout rather than connect to my home WiFi, so I could not complete the setup process.

Tech support was very patient and we tried: (1) an iOS phone; (2) an Android phone; (3) a Win 7 computer; and (4) a Win 10 computer. I have two different WiFi networks bridged together and it was the same for both routers. Finally, we tried removing the password from the router and that permitted me to complete setup.

Since the scale is now happily on my WiFi network, I probably can add the password back to the router, but would then have to disable the password again each time the scale needs to login to the network (e.g. after battery change or if the router lost power). Since that’s such a rare occurrence, this is not the worst kludge.

Just a head’s up in case anyone else runs into this and wants to save two hours on the phone with tech support!
  • Hi, since you rise the issue ( 2016 ) i have the same connectivity problem....! Until Feb. the scale was working well with my Wifi home network.

    Garmin Support  not have a solution yet..!!

    As you mention...i tried with several Wifi home routesr and the problem persist...!!

    My last try was using my samsung galaxy as a AP with a simple password ( only numbers) and the scale succesfully is now connected....!!

    So this is my only way to use it...!!

    Hey Garmin, this can not be possible..!!

    Please real a solution..!!

  • iam sending my garmin scale back to the seller.. iam tired of this *** product

  • Same problem in 2020.

    On Android device every attempt ended with timeout information (network with password or without password). 

    On iOS device every attempt ended with wrong password information. On network without password it was ok.

    After few hours and several resets of the scale I changed encryption on AP from AES to TKIP+AES and scale logged to encrypted wifi on iOS, on Android still same result with timeout.

  • Mine said it "timed out" when I tried to connect it to my wifi, but it in fact actually worked - just for some reason the phone app said it timed out. But the scale actually was connected to the wifi just fine. So after configuring the wifi on the scale, even if it says it's timed out trying to connect to the wifi, it's worth giving the scale a try anyways to see if it really is connected.

    My scale is kind of far from my wifi router, too, so I ended up buying a wifi access point and putting it closer to the scale, and now the connection is far more reliable. It used to have trouble connecting to the wifi about 1/2 the time before that. I think it doesn't have a very strong wifi antenna.

  • Hi,

    Are you using Cloudflare DNS ( on your network?

    TL;DR: Index Scale, for unknown reason, does not work with Cloudflare DNS server.

    Today I was debugging a similar connectivity issue. My Index Scale  was working perfect but stop this weekend. It was coincident with the fact I upgraded my router, hence reconfigured my wifi network. So, I started by looking into registration table of my WiFi access point (it is not the router of the network), Index was registering to WiFi. I then went to the router and checked DHCP, Index was getting an IP address from DHCP server on the router. However, at this point, WiFi icon was still just blinking in the Index display. Hence, seems that I needed to do packet capture on the network and so I did. Surprise surprise! 

    Index does a DNS request to DNS server provided in the DHCP, in my case, from CloudFlare. The DNS request asks the IP address of, DNS server sends a response back with IP address. Immediately, Index queries DNS again ask for, again gets valid answer from DNS and queries again... so on and so forth until it (scale) decides to timeout, one last try it does, it queries DNS about, again, gets good answer but do nothing and timout. Based on the DNS name I guessed that Index Scale is trying to sincronize its clock with an NTP server but I have no clue why it ignores DNS answer of its queries.

    So, before I upgraded my router, Index used to work. I turned on my old router and checked its DHCP configuration to see what DNS servers it was using. It was using Google's DNS I never saw this kind of problem in my near 25 years of experience in computer industry (*gets a good answer from DNS and just ignores it) but it doesn't hurt to try. Logged in my new router, changed DNS from to, reboot router, try Index Scale again (without changing its configuration or WiFi) and wow! It worked on the first try! I was not convinced so I changed router again to DNS server and Index stopped work right away. Revert back again to Google server and it works.

    I did query both servers with Linux command "dig" to see what I get back and both answered with the exact same IP. I did packet capture of Index transaction with both DNS server as well with the garmin servers. When using Cloudflares DNS, index does nothing other than repeatedly query DNS about "". In the case of Googles DNS, it queries once, get response and do NTP transaction to synchronize clock, than HTTPS to garmin's servers to update things there. Again, I have no clue on why it does not like DNS even do its answer is completely fine but that solved the issue.


  • This solved my problem too, which is still around on firmware v3.10! For the record, I had success with Google's DNS server and OpenDNS at 208.67. 222.222 and 208.67. 220.220. Thank you, JrBenito1979!

  • I was having issues connecting to WIFI with my phone (a Samsung Note8). I tried using my Samsung Galaxy Tab S4 and it worked immediately. In my phone Garmin Connect app  still says that the WIFI setup con the scale is incomplete, but everytime I weight in the weight get sync in both devices. I hope this help some of you.

  • I was having issues connecting to WIFI with my phone (a Samsung Note8). I tried using my Samsung Galaxy Tab S4 and it worked immediately. In my phone the Garmin Connect app  still says that the WIFI setup in the scale is incomplete, but everytime I weight in the weight get sync in both devices. I hope this help some of you.