Battery consumption: initial observations?

i know it's probably way to early to start this discussion, but i figure crowd sourcing may yield some insights. in short, after very disappointing battery use, in particular smart watch mode endurance on my 945LTE, i have been hyperaware of how much battery use my 955 Solar is using. just overnight (8-9 hours), i was surprised to see it dropped 3-4%. it may be that the battery gauge is poorly calibrated, but so far, even though one would guess it has a larger battery than the 945LTE, i'm finding consumption not very different.

on the positive side, for my one activity so far, a 70 minute run with Multiband+All satellites, i used up 6% which right on target with spec. (basically zero sun since i ran before and just as the sun was coming up).

i'd love to hear other people's impressions and experiences as some of you have had the watch (just a bit ;) ) longer.

  • i charged my 955 twice and my 935 is still at 50% xD

    granted it has less sensors and all but yeh..

    note : try a simple reboot, i wonder if it has the same behavior as mine (battery goes "up"). hasnt lost a percent since reboot also.. hmm.

  • I've had mine for less than four days and charged to 100% twice. In that time, I've logged 90 minutes of activities. It looses 50%+ each day. I'm also with on-demand 02. No map, music, or planned activity syncing happening that I can see. Firmware is up to date, etc.,. It's only slightly better battery life than a crummy Apple Watch.

    I've sent a message to Garmin asking for help, but am not hopeful. I see a return in my future.

  • Try restarting the watch after an activity, for me battery usage often goes crazy after an activity and it's fine after a restart again. 

  • Try restarting the watch after an activity

    Yeah, didn't work. Thanks for the suggestion though.

    I haven't yet done a full reset. That's my last resort.

    Most recently, I disabled the external sensors (RD-Pod, HRM-Dual) when they are not in use. So far that seems to have had a positive effect.

  • I haven't been super impressed by the battery life. I've seen what others are seeing. 3-4% loss each night. I've had it almost two weeks and it looks like this will be a once a week charge that's needed. I really thought it would be better. 

  • which watch face are you using? is the watch set to DND at night with sleep hours specified? except for one strange night, i'm typically seeing 1-2% drop with Glance Pro and Minimal Vertical 2 over a 9 hour period.

  • Just one of the stock watch faces. Yes, sleep hours are set. I guess I was expecting more than a week between charges but I do several exercise sessions a week using multi band gps so that may be what's draining it quicker. 

  • I can't find my comment from yesterday so might be different thread. But charged it to 100% and took off charge at 17.00 yesterday done one 15 min walk with the lowest GPS option. Dnd activated for 12 midnight to 8am and woke to 5% drain. Currently on 89% with no GPS useage or tracking activated today. Watch face is minimal vertical 2 as I remember someone saying it wasn't that draining. From last two charges including initial charge it seems to drop fast in first 24 hours then slows down midway. Will update tomorrow about next 24 hours.

  • got it. based on my very limited couple weeks of observations, i am finding smart watch usage is about 7%/day for Glance Pro, Minimal Vertical 2, both not showing 1hz seconds. All Satellites uses about 3%/hour for activities. i haven't used GPS only or Multiband to verify specs, but the couple of sessions i've done are consistent with specs. (6% for 1+ hour run with Multiband, and 4% for 2 hours of hiking but with the some sunlight augmenting it)

  • Thanks for this topic, I found a clear bug of 955 battery management:

    If I boot up the 955 and don't turn on any activities, the battery life show normal behavior, it drain 3-4% per day, but after finish some activity (like running), the battery will drain 1-2% per hour! Seems the GPS function is still working background after activity.

    Reboot the watch again, the battery again show normal behavior...

    Is anybody find same behavior?

    In my opinion, it's definitely a software bug, how to report the bug and ask Garmin to improve? Thank you!