This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Can't select target using map to navigate?

Perhaps I am overlooking something, but when navigating and using the map to (try and) select a target this doesn;t seem to work with the 955...

With the 945 I see a crosshair and long pressing start allows me to navigate to the point in the crosshairs, but on the 955 there are no crosshairs and long pressing start doesn't do anything so I can't find a way to navigate to a target point on the map... anyone?


The watch was delivered with 9.12 sw, I received a 10.10 update and now this issue is fixed! 


Nevermind, I THOUGH it worked but I didn't actually start the navigation. When I do restart the watch reboots... so still not working. And now I also can't see the crosshairs anymore, so still a mess unfortunately

  • Thanks for getting back to us on this one. i'm sure you appreciate that for everyone here this is a really important functionality on the watch. none of us want to be left with a device that we cant return at a later date if this turns out to be hardware related.
    out of interest, is this an issue with the new Fenix/Apex etc as well?

  • Any updates to this yet? I have the same problem... I bought my watch a week ago and am still in my return period. I'd hate to return the watch because in any other way I really love it, but if the navigation does not work properly and there is no near future update to fix this, I really have to consider it because navigation during activities was one of the main reasons I bought this watch.

  • my cousin has an EPIX and the feature works, he can easili select a point on the map and navigat to it

  • Heya Keith and all others.

    I have over the last few days tried this on 3 other devices. None of which worked. As far as I can tell so far this is not an isolated issue.

  • It's not, it's an issue with all (FR955) devices because well... it's a software/firmware issue. That not everybody uses this feature is something else, but if they would they'd find out.

  • Right... I'm not sure what you're getting at.

    The 955 doesn't work, mine, yours, likely everybody else's. 

    The issue is with the 955 which is just a summation of its hardware, firmware and software.

  • Oh, when I said "It's not" I mean "it's indeed not an isolated issue"... 

    And because it's mainly software issues they will occur with all devices with that software. (basically all devices) so more a confirmation of what you said ;)

  • Maybe some of you are interested in this, too: I had a chat with Garmin support about this matter as I'm still in my return period... They told me that there will be another software update in August (although the person I was talking to couldn't tell me an exact date) which they said will also bring some update to the navigation function. Hopefully this update will fix this issue! 

  • Thanks for the info... Hope it will not be august 31st but at least good to hear some expected date/timerange.

    Really hope it will be an actual proper update and not disappoint again

  • Would like to report another minor bug on Map unrelated to the subject. When viewing last activity under All Stats on 955,  zooming and panning on Map can only operated via buttons and touchscreen apparently is not working. Do you think this is a bug?