This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Can't select target using map to navigate?

Perhaps I am overlooking something, but when navigating and using the map to (try and) select a target this doesn;t seem to work with the 955...

With the 945 I see a crosshair and long pressing start allows me to navigate to the point in the crosshairs, but on the 955 there are no crosshairs and long pressing start doesn't do anything so I can't find a way to navigate to a target point on the map... anyone?


The watch was delivered with 9.12 sw, I received a 10.10 update and now this issue is fixed! 


Nevermind, I THOUGH it worked but I didn't actually start the navigation. When I do restart the watch reboots... so still not working. And now I also can't see the crosshairs anymore, so still a mess unfortunately

  • All,

    We hope to have a fix for this report in a future software update.  At this time we do not have a specific date for this release, but we will update this thread when more info is available.

  • All,

    Please see our recently released beta software for a fix addressing this report. If you prefer to not install this beta software, we hope to be rolling out a public software update soon, though I do not have a timeline for this release. If you are still seeing this issue after installing the beta software, please contribute your observations in the appropriate beta bug reports section of the beta forums for your specific device.

    Enrolling in Garmin Beta Software Program

  • All,

    We have released a fix in the latest (non-beta) software release that should resolve the report for most users experiencing these symptoms.  The software release should continue rolling out to all users in the coming days.  If you are still experiencing symptoms like the original report here, please start a new thread in the main forum.