This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

When are Garmin going to fix this ridiculous Jaybird Bug

Hi everyone,

putting this out there as normally when I encounter a bug I just give it a bit of time and its usually fixed in the next release but this issue where Garmin seems to have cocked up the BT connection to Jaybird headphones has been going for months now. They seem to have messed it up around Sensor Hub 5.3 and its not wired properly since and from what I can see people are having the same or similar issues.

Some of the things I've tried are deleting the headphones from the watch, factory resetting the headphones, deleting Spotify and reinstalling. Occasionally doing all this seems to fix the issue for a few runs but then it suddenly just starts again and it becoming really annoying!

For the record, I have the following issue:

Garmin 945, Jaybird Vista and Spotify

Run with one headphone when running

Music plays fine if just stream music, but as soon as I start an activity it times out at almost exactly 5 minutes (though this time has changed sometimes!). Turning off the headphones and turning back on seems to fix for another five minutes but if for example I try to reconnect from the watch instead of turning headphones off, the headphones say 'connected' but nothing plays so you press play on the headphone and you just get white noise which I gather is jus the bluetooth playing when there is no actual signal?

Anyone found any better solutions though I cant think anything can fix it besides Garmin pulling their finger out:(

  • I updated to the beta firmware on Saturday, went for a run and it happened within 4 minutes. 

    As someone advised in another thread, I removed the headphones from the watch, turn the watch off, restarted it, readded them and went for a run yesterday and had no issues during the 1hr06m. Fingers crossed.

  • Same here. Ran for 97 minutes without problems. Fingers crossed here too.

  • I've been for 3 runs of 30 mins + now since updating to the new beta firmware.

    All good so far :0)

  • Agreed, this fix is not sufficient. Hoping that running with my phone is short term.

  • Again - 80 minute run and no headphones issues. :-)

  • The connection failed after 10 minutes of running. Worked ok for 2 runs after I reseted the watch and Jaybirds and reconnected BT. I am using the beta software that is supposed to work fine, but it isn't.

  • What watch do you have? I used to have my Jaybird Vistas connected to my iPhone. Since I removed their connection to my phone, I’ve had two successful runs.

  • Forerunner 945. I don’t use my iPhone while running, only my watch, I even don’t connect them to my phone at all. I had two successful runs, but the third was unsuccessful after 10 minutes. 

  • Ah how frustrating. I had two two hour runs on the weekend and it was perfect, but I guess it might just happen again soon. 
    you followed that advice of removing then restarting the watch?

  • Beta 6.04 DOES NOT fix the problem. Have had two runs riddled with problems.


    5 miles, 38:27...I had 16 Disconnects. The longest connection lasted 5 minutes, the shortest about 20-30 seconds. This is unacceptable. I have reflashed Vista firmware, factory rest, and only paired to watch. Have had watch forget connection and restarted and reconnected. If i connect and listen to music outside a workout, no disconnects. After I hit stop on the watch after a run/activity, now listening for 10+ minutes without disconnects. Garmin, get it together. It has been 3+ months with core functionality crippled. Headphones disconnecting every 2.5-3 minutes on average is not acceptable. The Vista work with every other device I have tried.

    Another thing, the 945 no longer gives me any interval prompts through the vista. When connected with headphones and watch to phone, i get the updates. When listening to music through phone speakers and watch connected, I still get voice prompts. I used to get them a long time ago through the vistas, LIke 6+ months ago. How is the system this broken?