This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

FR255M can't power on

Hello, I successfully set up my new FR 255 previously after that came to me, and after one week I power it off and later I wasn`t able to power it on. I tried to press and hold light button up to 30 seconds -> nothing happend, tried to press light button for one second -> nothing happened, plug watch to USB -> nothing happened. FW version is 10.10

Has anyone else same problem or should I claim to support to my seller ?

  • That also worked for me. For me, after 3 days it suddenly showed the normal display and 1% battery. I charged it and everything has been perfect since. I dared to restart it and it also worked fine  

  • Similar issue. I just bought a Garmin Forerunner® 255 Music yesterday (10/07/2022)
    After the initial setup, software has been updated to version 10.10 via Garmin Connect.
    Now, the Forerunner® 255 Music doesn't turn back on after turning it off.

  • Bought mine last week. did the update and turned it off for the first time. Wont turn back on.

    Lets see what happens next. :(

  • Hello all,

    For assistance with a device experiencing these symptoms, please reach out directly to your local Garmin Product Support team.

    Garmin Product Support

  • I found a solution by performing a hard reset with the next buttons trick:

    Press and hold the Down, Start, and Back buttons. Power the watch on while holding these buttons. After the first beep release the Start button. After the second beep release the remaining buttons.

    In my case, after this the watch could boot again with factory settings.

    Does anyone know if the last update (11.12) fixes the problem?

  • I just suffered from this. Really annoying. It was 11.12 but still problem continues. Do not turn off your watch! 

  • Similar problem here: Garmin Forerunner 255 Music has been working fine for months, then shut down in the middle of the night last night (unexpectedly, since there was still ~20% charge). I plugged it in for a couple of hours this morning, but the watch wouldn't turn on. Tried again using a different USB socket, and double checked plug, etc. Still wouldn't turn on.

    I held down the Start button for 30 seconds, then plugged in the watch. Finally, it's charging and has turned on.

    That's OK for the moment, but I'm now concerned that the watch might unexpectedly shut down during an event, or just become unreliable generally. If it happens again, I guess I'll need to return it.