This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

HRM PRO connectivity problems since firmware update

  • I updated my Strap and had and have problems.

    After updating the strap did not connect anymore. Did a soft reset on my watch. Deleted it from the app. Only thing that helped was taking out the battery from my Strap to reset the strap.

    After that my watch found the sensor and the app found the strap finally 

    But unfortunately it is still not working correctly. Connected via Ant+ to my watch and via Bluetooth to my headwind , i can see it on Zwift it has four green bars in the Zwift app, but does not send any heart rate to the app. Disconnected etc. no change. Very annoying. I definitely have only problems with the new firmware. The strap worked perfect before and now it's awful 

  • I have the same issue but changing the battery didn't help. I can't have it detected anymore

    Have you updated Garmin Connect?

  • I updated the strap through the Garmin App on my phone.

    I am not sure, if it is due to the latest firmware of my strap or due to the new beta 8.18 on my Fenix 7.

  • I am seeing a similar issue with the HRM Pro. I’m using a 945 which has just received a firmware update as well. I raced a half marathon on Sunday and was able to get it to display the HR data after a lot of resetting my watch (soft power off and hard power off). Tried again this evening and no luck at all this time. I’ve had the strap since October 2020, and I’ve ordered a replacement from Amazon as I’m not sure what’s wrong. The strap connects to the watch, but doesn’t get any HR data from it. 

  • I’ve also tested connecting the chest strap to my phone, which the Garmin connect app sees as connected. Loaded up Strava, and selected the HRM pro as the external HRM. This is seen by the app, but no HR data is being sent. 

  • I have no problems with connectivity to my fenix or Zwift PC via ANT+.

    However, Bluetooth connection to my Samsung Android tablet (S7+) has been flaky before and after the 8.10 firmware update. Connection of any kind is kind of dodgy, but I also see a connection made, but without data. I recently tried a complete uninstall and reinstall of Zwift on my tablet. Only one short run since then, but at least the connection held up. Unfortunately I now have an injury that will stop me testing further for a while. It may be worth giving uninstall/reinstall of Zwift a shot.

  • I'm having the same issue. It worked this morning after my run put in on 2 hrs later and refused to connect to anything. Phone won't even pick it up as blue tooth device 

  • I have a similar issue I ran the morning strap worked fine. Then put it on 2 hrs later and refused to connect to anything.. I don't even know if it had a software update. It's just completely dead. And I need it for a weekend away 

  • My new strap has arrived, connected and upgraded to 8.10 firmware, and works perfectly. I’ve contacted Garmin about the old one being faulty while < 2 years old, so will see if anything comes of that. 

  • I use the Pro to connect to my Fenix via ANT+ and to a Coros Vertix 2 via Bluetooth. The firmware update bricked all Bluetooth functionality. I reported to Garmin via chat; they have escalated to the A Team for Monday morning. Back to the old black band until this is fixed. 

  • Same here. HRM-Pro updated to v8.8.0. Everything worked fine before the update. Now my heartrate is erratic going from 200+bpm to 0 and so on - when connected to the F45 monitor via ANT+. My husband has the same exact strap and his works just fine, and he did not perform a firmware update on his. I take care of my strap, and the Garmin guidance about the issue was not helpful. I wish there was a way to reverse the firmware update.