HR accuracy when not in activity

Hello,

I received my venu 2 5 days ago and noticed a lack of accuracy In HR monitoring mainly when not in an activity. If I start an activity it seams to go fine when compared to a band, but during the day is always around 65-80 even when I’m band is around 110 or more. 
also noticed that during if I’m cycling and in the edge I see 135 hr, in venu (without starting an activity) it’s still at 80.

anyone else? This is anoying and I might send the watch back.

thank you

  • Hi is there any update on this please

    Dean

  • Garmin-Kevin - any updates? I see that the same issue is in Venu 2 Plus. 

  • It would be interesting to hear from any new Epix 2 owners too - see if that has the same HR problem (out of an activity) too? ....you have to wonder if that's how they're getting amazing battery life stats vs Apple?  

  • I’ll confirm that Plus does the same thing. Everyday, walk around the house/work HR seems accurate. As does workout HR when IN AN ACTIVITY. But if don’t start an activity, HR doesn’t seem to want to go too far above 85 or do. I’m using a chest strap w/ Wahoo or broadcasting from the Venu to Zwift and it works fine. I’m just deleting the second/duplicate entry from Connect and Strava. 

    My question for you all is, if I do an activity on the Venu and don’t save it, the “delete method” mention earlier, that activity won’t show up in the watch but what about the data (caloric, intensity minutes, etc.) will that still be recorded and reflected in their respective categories?  In other words, does not saving the activity also toss out your metrics on the watch?

  • Everyone having a problem with this - 

    Have you tried switching your Data Recording from "Smart" to "Every 1 Second" in your device settings in the Connect app? I'm not having this issue, but I also switched that setting during setup because I need particularly accurate heart rate readings for health reasons, so I'm wondering if the "Smart" setting isn't correctly sampling when idle. 

  • I must say I don't know for sure for Venu 2, but I can confirm for my Vivoactive 4 that the setting "every 1 second" for sampling rate didn't solve the problem.

    I bring to mind that this bug/problem is not only on Venu 2. It was on my Vivoactive 4 and I'm pretty sure it's all across multiple models and it runs for years. I just don't know why nobody from Garmin gives a ****.

  • This did not solve the issue for me either.  I understand why it's being implemented this way.  However, there has to be a method for improving the sampling rate in concert with a jump in HR.  As I mentioned, mine seems pretty accurate when relaxing or walking around the house.  But if suddenly decided to do a HITT workout, the device should recognize my heart rate has jumped 20, 25, 30 beats/minute, and at that time it should shift into the same sampling mode used for predefined activities.

  • I can confirm that the data is still recorded even when you discard the recorded activity.

  • Thank you for confirming this.  Under the circumstances, this is positive.

  • I have a fenix 6 Pro and a Venu 2 and both have this problem. Fenix even more so. When not in an activity mode the optical lights on both watches flash , presumably as a power saving method. When switching to activity mode the optical lights stop flashing are on continuously resulting in more accurate heart rate reading. If you enable auto activity start on the Venu 2 this seems to improve the heart rate reading presumably as the watch tracks you better.