Is my Edge getting confused when navigating a route?? See pics

I'm having a lot of problems navigating with my Garmin Edge 530, since I purchased the unit about 6 months ago.  I'm in Australia, and i have an Australian-delivered unit.  I had another terrible experience on the weekend and decided to try to figure out what was going wrong.

Here is a picture of the Edge 530 when I'm approaching a roundabout. The gpx route is to turn to the right. 

The roundabout icon on the top left of screen shows the exit in the correct direction, but it is suggesting i ride around the right side of the roundabout (wrong for Australia). 

The 3rd exit is correct for riding around the left side of the roundabout. And the name of the road to follow is correct.  So the top right of the screen works.

The arrow on the map says to turn left which is completely wrong.  I followed the arrow, and shortly after the unit told me i was off course. The map does not look anything like the OSM open street map on which the Garmin map is based.

(also not sure why i have 2 different distance markers, the lower one 98m is correct)

  

OSM shows the correct Australian navigation around the roundabout. - openstreetmap.org

I'm about 100m from the roundabout.

Here is a second example.  The route per the gpx is the right hand turn.  See description with each picture below.  Can anyone explain what is happening with my unit?  I would be very grateful, thanks.

The OSM direction around the roundabout is correct for Australia

The roundabout icon at the top left of the Edge 530 is indicating the wrong direction this time.  It also says to go around the right hand side of the roundabout, also wrong. 

At the top right it says to take the 3rd exit, which is correct for going the correct way around the left side of the roundabout.  The street name to exit on is also correct out of the 4 uniquely named streets!  So the top right of the screen works again. 

The Edge 530 map again does not look like the OSM map.  You can see there are not any streets on the Edge 530 map approaching from the north, as indicated by the north pointer on the screen.  But as you can see from the OSM map the approach is almost directly from the north (page orientation).

  

The distance of 70m is wrong and 12m is correct.

So I am at a loss as to how to solve this. Based on these two examples I feel that

  • the top left roundabout icon has some form of American configuration,
  • the top right of the Nav screen works for Australia as intended,
  • the map shown is not related to the intersection being approached, and
  • the arrow direction on the map is getting confused by the mix of configurations. 

I've contacted the retailer, and I think I'll take the bike out again on a planned route to confirm these theories.

  • The DEM map is just an elevation map.  It contains no roads or routing information so it shouldn't interfere with routing.  The Cycle Map contains the roads and routing information.  You could try disabling the DEM maps and see if it does anything.  Disabling them won't stop anything on the Garmin working.

  • The "Garmin Cycle Map AUS/NZ 2018.20" map is the only one that matters.

    (Don't waste your time seeing if disabling the other maps do anything. That will change nothing.)

    >>"The Garmin road map matches the OSM map perfectly."

    The "Garmin Cycle Map" uses OSM data (so, it should match).

    >> "yes you're practically right in that the map used to create the turn by turn directions does not match the map displayed on the device's map screens".

    Try a route planner that lets you use OSM maps (most of them do).

    ======================

    For the last roundabout show, Google Maps and OSM are pretty-much the same.

    The 530 screen shot before the one just before seems to be showing the basemap (not the detailed map). The instructions at the top of the screen show a roundabout (and the correct turn instructions).

    That seems like a bug with respect to how the pop-up map is displayed.

    Try disabling the basemap (maybe, it will display the correct detailed map instead).

    (By, the real-world pictures don't really help: the Garmin has no idea what the real world looks like.)

  • I think we have clear consensus that the turn by turn pop-up map does not align to the OSM, and this is a bug, which effectively makes TBT unusable.  Here is another example from a new ride today.

    As far as I can find from Strava Support, the web-based Strava route planner uses OSM.  So, there should not be any map conflicts.

    Lastly, this is my friend's 820 on the same ride/route as me with the 530. He is running the 2018.10 map vs my 2018.20, but I don't think that is the difference.  A left turn was of course the correct one.

  • I think I know what the issue is with the screenshot where you say the TBT map doesn't match the underlying map.  I get this issue myself with my 830 and it confused me at first.

    The map that pops up does match the underlying map (it is the same map).  The problem is that the the unit zooms in way too far so you can't see the whole junction (which is what you really need to understand what to do) and it looks really confusing.  This is a bug.  Sometimes the turn notification map zooms to a sensible level.  Sometimes it doesn't.

    If you look at the same location after scrolling to the map screen and zoom a long way in you will see that it looks the same.

    You could try turning auto zoom off and setting the zoom level at a sensible point and see if the TBT pop up map look better.  I haven't tried this myself so I don't know if it would help.

  • >> "I think I know what the issue is with the screenshot where you say the TBT map doesn't match the underlying map.  I get this issue myself with my 830 and it confused me at first.

    The map that pops up does match the underlying map (it is the same map). "

    If it was the same map, the two magenta lines would be in the same location and both would be on the road.

    The normal map view is using OSM. 

    The pop-up looks like it's using a different map

    The only alternative map (that had roads) is the basemap. Try disabling that.

  • >> "Is it possible that my device has reverted to some form of American settings?"

    The settings are in the map.

    >> "As far as I can find from Strava Support, the web-based Strava route planner uses OSM.  So, there should not be any map conflicts."

    That stuff looks fine.

    The real world picture is useless. The Garmin only sees the maps.

    It looks like the pop-up is using a different map. 

    Try disabling the basemap.

  • If you zoom far enough in the magenta lines tend not to quite line up with the roads. At normal zoom levels this doesn't happen.

    The basemap doesn't have much detail on it so I would surprised if it contained all these smaller roads.

  • Wongataa you are exactly right that the turn by turn directions show the map zoomed in way too far! Well done, that is one of the bugs! 

    The zoom for the turn by turn puts the scale at about 5m per ~8mm of screen, while the scale needs to be at about 20m to actually understand the intersection.

    I had auto-zoom turned off from mid-ride, with the map adjusted to 20m on the scale.  It appeared not to have any effect on the turn by turn zoom, e.g Barry St.

    I had the Worldwide DEM Basemap disabled for the whole ride, was just using Garmin Cycling map AUS/NZ 2018.20 and DEM AUS/NZ 2017.20

    This does not yet explain why the Garmin thinks I'm riding on the right side of the road.  And don't say its the map.

  • That’s interesting. 

    The tracks still seem off.