Is my Edge getting confused when navigating a route?? See pics

I'm having a lot of problems navigating with my Garmin Edge 530, since I purchased the unit about 6 months ago.  I'm in Australia, and i have an Australian-delivered unit.  I had another terrible experience on the weekend and decided to try to figure out what was going wrong.

Here is a picture of the Edge 530 when I'm approaching a roundabout. The gpx route is to turn to the right. 

The roundabout icon on the top left of screen shows the exit in the correct direction, but it is suggesting i ride around the right side of the roundabout (wrong for Australia). 

The 3rd exit is correct for riding around the left side of the roundabout. And the name of the road to follow is correct.  So the top right of the screen works.

The arrow on the map says to turn left which is completely wrong.  I followed the arrow, and shortly after the unit told me i was off course. The map does not look anything like the OSM open street map on which the Garmin map is based.

(also not sure why i have 2 different distance markers, the lower one 98m is correct)

  

OSM shows the correct Australian navigation around the roundabout. - openstreetmap.org

I'm about 100m from the roundabout.

Here is a second example.  The route per the gpx is the right hand turn.  See description with each picture below.  Can anyone explain what is happening with my unit?  I would be very grateful, thanks.

The OSM direction around the roundabout is correct for Australia

The roundabout icon at the top left of the Edge 530 is indicating the wrong direction this time.  It also says to go around the right hand side of the roundabout, also wrong. 

At the top right it says to take the 3rd exit, which is correct for going the correct way around the left side of the roundabout.  The street name to exit on is also correct out of the 4 uniquely named streets!  So the top right of the screen works again. 

The Edge 530 map again does not look like the OSM map.  You can see there are not any streets on the Edge 530 map approaching from the north, as indicated by the north pointer on the screen.  But as you can see from the OSM map the approach is almost directly from the north (page orientation).

  

The distance of 70m is wrong and 12m is correct.

So I am at a loss as to how to solve this. Based on these two examples I feel that

  • the top left roundabout icon has some form of American configuration,
  • the top right of the Nav screen works for Australia as intended,
  • the map shown is not related to the intersection being approached, and
  • the arrow direction on the map is getting confused by the mix of configurations. 

I've contacted the retailer, and I think I'll take the bike out again on a planned route to confirm these theories.

Parents
  • I would double check the roundabout in OSM to see if it goes the correct direction there.  If it is correct in OSM then it is likely an error on Garmin's part when they made the map form the OSM data.  Roundabouts in the Garmin map in the UK have issues as well so it could be down to which side of the road you drive on.

Reply
  • I would double check the roundabout in OSM to see if it goes the correct direction there.  If it is correct in OSM then it is likely an error on Garmin's part when they made the map form the OSM data.  Roundabouts in the Garmin map in the UK have issues as well so it could be down to which side of the road you drive on.

Children
No Data