Fenix 6 Series - 4.63 Beta Release

Hello Fenix 6 customers,

Please ensure that you are downloading the correct beta software for your specific device.

Fenix 6s: https://www8.garmin.com/support/download_details.jsp?id=15166
Fenix 6s Pro: 
https://www8.garmin.com/support/download_details.jsp?id=15164
Fenix 6: https://www8.garmin.com/support/download_details.jsp?id=15162
Fenix 6 Pro: 
https://www8.garmin.com/support/download_details.jsp?id=15160
Fenix 6x Pro: https://www8.garmin.com/support/download_details.jsp?id=15168

Instructions for installation are available below the change log on each of the above pages.

4.63 Change Log Notes:

  • Fixed an issue where the stress score could intermittently get stuck at 25.
  • Fixed an issue where the device will crash when trying to manually connect to an ANT sensor after enabling Airplane mode.
  • Fixed an issue where one would see a Wifi error message when launching the Golf activity. (Pro models only)
  • Fixed an issue with golf maps drawing incorrectly after the last beta update. (Pro models only)
  • Improved Indoor Bike OHR performance
  • Brought in improvements for CIQ.
  • Brought in improvements and bug fixes for music. (Pro models only)

Current beta peripheral software version numbers:

GPS: 2.60
Sensor Hub: 3.01
ANT/BLE/BT (Pro models): 4.30
ANT/BLE (non-Pro models): 2.10
Wi-Fi (Pro models only): 2.60

Please note, the beta updates released on these forums are not suitable for APAC region devices.

Please send all bug reports to [email protected], and indicate which model of the Fenix 6 Series you have in the subject line.

Parents
  • OK- updated to 4.63beta with it's peripheral software updates. 

    BUG REPORT

    1.  At least for running, the OHR still doesn't work for me.  Irregular and typically 20-30bpm higher than actual.  

    2.  During a run activity- the data page background color keeps swapping.  Black on white to white on black.  and- it doesn't matter if I have it start out with a black background or white background setting.  

    3. During a run activity, If I scroll to data page 2 or 3... after a few minutes it's back on page 1.  No- I don't have autoscroll on.

    I did notice that I had autoclimb on with it set to the default of 1800ft/hr.  perhaps this is being triggered?  but I was running on a river path and in a park... both very very flat courses.

    4.  GPS Performance:  eh- if the traces are any smoother... it ain't much.  Maybe a little.  The distance seems pretty accurate- as I was running on a marked course today, but the GPS traces are wobbly and often 100ft from where I actually ran. No apparently improvement for me.

    I have sent items 1-3 along with the requisite files to the bug report email address.  

Reply
  • OK- updated to 4.63beta with it's peripheral software updates. 

    BUG REPORT

    1.  At least for running, the OHR still doesn't work for me.  Irregular and typically 20-30bpm higher than actual.  

    2.  During a run activity- the data page background color keeps swapping.  Black on white to white on black.  and- it doesn't matter if I have it start out with a black background or white background setting.  

    3. During a run activity, If I scroll to data page 2 or 3... after a few minutes it's back on page 1.  No- I don't have autoscroll on.

    I did notice that I had autoclimb on with it set to the default of 1800ft/hr.  perhaps this is being triggered?  but I was running on a river path and in a park... both very very flat courses.

    4.  GPS Performance:  eh- if the traces are any smoother... it ain't much.  Maybe a little.  The distance seems pretty accurate- as I was running on a marked course today, but the GPS traces are wobbly and often 100ft from where I actually ran. No apparently improvement for me.

    I have sent items 1-3 along with the requisite files to the bug report email address.  

Children