Complete
over 1 year ago

WERETECH-8014, MODUS-3374

vivoactive 3 phoneConnected always true

Seems that as a result a recent firmware update to the vivoactive 3 the Sys.getDeviceSettings().phoneConnected as well as settings.connectionInfo[:bluetooth].state always return true/CONNECTION_STATE_CONNECTED regardless if the phone is connected or not.  These calls have been working fine for many months.  Is there a new process for getting connection state?

  • VA3 MUSIC with FW 4.90 has the same problem, the phone seems connected even when it is not! After turning off the watch and restarting, it started showing the correct connection status on the watch face.  Cycling the phone BT off/on was being reflected correctly on the watch face.  However, later it was back to only showing always connected even when the phone had BT disabled or phone was out of BT range. Restarting the watch restored functionality. Only native watch face works fine.

  • Yes, at this point it would be helpful if you sent your source to [email protected] Thanks for your help!

  • Sideloaded has the same issue.  If you want I can provide my app source for you to test/inspect.  I only write watch faces so can not comment on other types of apps

  • Everyone who is seeing this issue, do you also see this issue on side loaded apps? or is this only happening on apps downloaded through the app store?

    I couldn't reproduce this at all, until I installed one of your apps from the store rather than side load my app. If you have a VVA3, I would appreciate it if you could attempt to side-load a copy of your app and see if this issue is still occuring for side-loads.

    Also, are any of you seeing this issue on an apptype other than a WatchFace?

  • I also have two user reports for exactly the same issue on a VA3 with 6.90