Complete
over 1 year ago

Garmin Connect Mobile 4.22 for Android includes the changes to allow HTTP on 127.0.0.1.

Connect version 4.20 broke local http access?

Getting several reports of functionality no longer working, it looks like Android Garmin connect app version 4.20 may have broken web request to local host via urls like http://127.0.0.1:17580/sgv.json?count=3

  • ok, looks like the the issue is solved by allowing http to 127.0.0.1

    But, what exactly is the recommend implementation for local-network IoT and Smart Home usecases?

    Should all end-uses now install certificates on their raspberry pi or should the widget require a additional companion-app that does the http communication?

  • because this issue is solved only on localhost I installed the android app ¨Fwd: the port forwarding app¨¨

    I configured a port forwarding, When I send a command via the IOT widget  to this localhost port forwarding active;  I got the feedback Send Ok. When I disable Port forwarding I got error -300.  But the command does not reach the Tasmota device I try to remote control.  When I copy the cmd URL from the IOT widget and paste this in the browser of my phone the tasmota device will be activated:  So the Fwd app is forwarding the command.  But still there is an issue in between the IOT widget and my tasmota device. Does anyone has a tip for me to solve this issue?

  • that sounds right - it worked for me, i was able to use makeWebRequest on http://127.0.0.1:3080/foo.json and the fwd app redirected it to http://192.168.1.127:80/foo.json.

  • Hi Horsetooth,

    could you explain a bit more what exactly you did? I tried to sent a request form the garmin app to
    http://127.0.0.1:65535/xyz

    and in the port forwarder app I added a setting with
    target 192.168.0.40 on port 80. But I get a response code -300 in the garmin app.