This app is not compatible with the selected device

A user has reported a problem installing an app on his Edge 820 He gets the "this app is not compatible with the selected device" error. I run the app without any issues on my 820. The app manifest lists 820 as a supported device:

<iq:product id="edge_1000"/>
<iq:product id="edge_520"/>
<iq:product id="edge820"/>

Any idea why this may be happening?
  • What devices is it available for if you look at "Compatible Devices" in the app store? What you have on your computer may not be what'sin the store. Maybe an earlier version?
  • Can others with a 820 download it? Maybe someone here has access to an 820 and could try.
  • I just tried with an Edge 820 here at the office and had no errors. Any more info about specifics? Software version? APAC, EU, US version of the device?

  • The user only provided the firmware version:
  • Check with the user as to where they bought the 820, and the languages it supports. That can point to an APAC device. If they bought it in China and has Chinese, it's APAC for example.

    APAC devices have different part numbers, and support for APAC devices is a bit hidden in CIQ, but comes into play when a .iq is built, as it's also built for the APAC part number.

    You want to make sure that you are using the latest SDK when you build a .iq. What SDK did you use to build the .iq?
  • He verified his device is the APAC (Japanese) version. I built the current .iq using SDK 2.2.6. I'm going to rebuild using 2.3.4 and we'll keep our fingers crossed.
  • Former Member
    Former Member over 6 years ago
    The logic to decide what part number variants to support takes into account devices specified, languages specified and the minimum SDK version. If you're specifying that you support Edge 820 and you are either including one of the part number's languages (English is in all of them) or you aren't specifying you support any languages (we'll build for all of them) then upgrading the SDK version should address the issue.
  • It looks like upgrading to the latest SDK did the trick. I got an email from the customer and he was able to download the app now. BTW, I selected English as the only supported language when I build the .iq. Thanks a lot for your help.
  • I realise this is an old thread, but I have a user In Japan who has an Edge 1030.  I got him to send details of the device firmware, etc.  It's 11.10 and it says it supports Connect IQ SDK 3.2.4.  I have three apps in the apps store, two of which he has installed on his device.  The manifest for these apps specifies English, min SDK of 2.4.0 and the Edge 1030 device.  He wants to install my third app (In The Zone) which is an updated and combined version of the other two apps.  The manifest for this app specifies English, min SDK of 3.2.0 and the Edge 1030 device (The app shows weather and was built with Strict Type checking).  The user cannot install "In The Zone" - he gets the message which is the subject of this thread.  He can see it in the Connect IQ Store.  I can't see why the app won't install on his fully firmware updated device, when the other two apps do.  Any clues?