Hello,

We've released SDK 3.1.5 which includes device support and version changes, as well as some minor updates. Here is a list of some of the changes and updates:

General Changes

  • Add support for the MARQ Adventurer and MARQ Commander.
  • Update minimum firmware and supported connect IQ version for the vívoactive® 3 / music / LTE devices
  • Update minimum firmware and supported connect IQ version for the MARQ and fēnix® series devices.
  • Fix MapTrackView.setMapVisibleArea to update the map everytime it is called.
  • Add new DeviceSettings API isGlanceModeEnabled to determine if widget glances are enabled.

Simulator Changes

  • Fix issue that prevented WiFi/LTE connection info from being provided on devices that did not have audio content provider app support.
  • Fix a few simulator crashes that can occur when pairing BLE sensors.
  • Fix incorrect data field layouts for the GPSMAP® 66 and 86 devices.
  • Fix issue with fēnix® 6 series fonts being slightly different from device.
  • Fix incorrect supported connect IQ API version listed for the vívoactive® 4 / 4s and Venu.

Compiler Changes

  • Fix a crash that can occur in when compiling an animation from a GIF with frame delays set to 0.
  • Fix the app memory limit check for background / glance apps, which should not be checked when a device does not support the app type.