Dexcom G7 not working with existing GC Dexcom data field and glance/app

As the title states, I'm wearing a new Dexcom G7 CGM and have the app installed on my iPhone (works perfectly as long as the iPhone is within 20 feet).  Installed the Dexcom app and data field from CG and walked through the install steps on my Fenix 7X Solar.  No blood sugar data is showing up on the watch data field or app.  Strangely the graph of the glucose data points populates with tiny dots representing blood glucose levels but no numbers and the main data field in the app says "NO DATA".  I started a run and got one initial glucose level then nothing throughout the rest of the 45 minute run, even though I had my phone with me.

It may just be early and there hasn't been time to get the Dexcom apps updated to be compatible with the newer G7 sensor?  I'll be patient.

  • Thanks for the additional details  Jason!

  • This! Worked like a charm. I just uninstalled the follow app after I followed myself. Seems to be working.

  • Nice one Jason. That worked for me. 

  • Thanks for the suggestion, Jason! This worked, but this really does not make any sense from an end user perspective as to why Garmin would have implemented it this way. I shouldn't have to follow myself just to get the data. This certainly did not work this way with the G6.

    I've logged a ticket with Dexcom support through the Garmin IQ app. Hopefully they can fix this to allow it to work like the G6.

    Thanks again! At least for now I have the info back on my wrist.

  • You are most welcome!  Good idea to engage support.  Hopefully they won't tell you "it's not a big... it's a feature!  Hahaha 

  • Just to be clear, this need to share and follow is not imposed by the Garmin implementation—it's something that is controlled on Dexcom's end, and they're looking at solutions so this won't be required in the future.

  • I wanted to share an update for those following this thread.  I previously had trouble with my Garmin Edge 1030 populating the G7 data.  What I have found over many uses now is that approx 50% of the time I need to open the Garmin Connect App and navigate to the edge data fields settings and again “turn on” the Dexcom data field.  It seems that it loses the connection to the data field or simply turns itself “off” and by entering and reselecting the connect IQ Dexcom data field it is reactivated.  It takes an extra step each time, but at least it works. 

  • Hey ,

    your are talking about Bluetooth communication issues. I face exactly this problem. When connecting my iPhone to my Garmin connect app, the Bluetooth connection to my Dexcom G6 app is lost. When starting a ride (I am using the Edge 1040 Solar - but had the same problem with an older device), the glucose is therefore not displayed. The connection to the Garmin connect app seems to work fine but somehow kicks out the Dexcom Bluetooth connection. Is there a way to solve this?

    Thanks and best!

  • I experience this also quite often.  It seems to happen if I get out of Bluetooth range when I run back into the house to grab something.  Other times ot won't connect up on its own.  The only solution I've found is to reboot the Garmin and sometimes it takes a couple of tries. Sometimes it will drop after the ride starts.  In this case I pull over stop but not cancel the ride and reboot the Garmin.  

    Hope this helps!


  • this worked for me. Saw the green Dexcom after signing back in for the G7 within the Garmin App. Once I sent myself a share invite and accepted then completed the invite, I rebooted the Garmin to see the glucose readings showing. 

    Actually the above only worked once, every subsequent ride still shows the broken cloud as in data not available. Very frustrating that the only change was the G7 from the G6.