Bug: If you have more than 1 device synced with Connect IQ, the selected device is forgotten after switching away from app

This means that if you were looking at the page for a given app after selecting the 2nd device, if you switch away from Connect IQ and return to it, you'll now be looking at the page for the 1st device (with no indication that this is the case).

1) Sync 2 devices with Connect IQ (e.g. 935 and 945 LTE)

2) Install a data field app with settings, only on the 2nd device

3) Connect the 2nd device to your phone via bluetooth. Do not connect the 1st device

4) Open Connect IQ, select the 2nd device and navigate to the app page. Note the Settings and Uninstall button

5) Switch from Connect IQ to another app (but don't force close it)

6) Switch back to Connect IQ - note that the Settings button goes away and Uninstall changes to Install

7) Press Back a couple of times and note that the selected device is now the 1st device

This is pretty annoying as it means that switching away from Connect IQ (e.g. to copy some text or look at docs) breaks your workflow.

It also seems that it could be an issue if an app with settings was installed on both devices, and both devices were connected. I haven't tried this, but it seems that the user might be able to accidentally change settings for the wrong device in this case.

  • Does the issue occur after pairing both devices as listed? support.garmin.com/.../

  • Both devices are paired with the Connect IQ app. The 935 was paired several years ago (probably around the time that the Connect IQ app was introduced), and the 945 LTE was paired recently.

    I don’t remember if I had to explicitly pair the devices with the Connect IQ app, or if the act of pairing with the Garmin Connect app was sufficient.

    I think this bug is pretty easy to recreate, as all you have to do is pair two devices, connect the 2nd device via bluetooth, but leave the first disconnected.

    Now in the Connect IQ phone app, navigate to a CIQ app which is installed on the 2nd device. The app page will include buttons for Settings (if applicable) and to Uninstall the app. Crucially, the CIQ app page does not indicate *for which device* these buttons apply. (The only way to find out is to navigate back)

    While viewing the CIQ app page, switch to another iOS app on your phone.

    Now switch back to Connect IQ. Originally the Settings button disappeared, and the Uninstall button changed to Install. Now the buttons stay the same, but pressing Settings does nothing, and and pressing Uninstall gives me an error message: “Cannot uninstall application while device data is loading”

    At this point, if I press back once, I get a page that says “server connection error”, instead of the list of other apps in the same category. If I press back a second time, I get the 935 page (even though I started with the 945 LTE page.

    TL;DR: whenever you switch away from the Connect IQ app and switch back, the app forgets which device you were looking at and defaults to the first device in the list.

    I think this could be dangerous if both devices are connected, as you could accidentally modify settings or uninstall apps for the wrong device.

    A related usability problem is that there’s absolutely no indication which device you are currently working with, after you tap on an app category for a device.

  • So this bug is still happening, almost two years later. Is there any intention to fix it?

    I realize it's an edge case that someone has multiple devices in the Connect IQ app and only one of them is connected via bluetooth, but it's kind of annoying.

  • I have the same problem. Connect IQ never automatically connects to the watch I’m current wearing without manually connecting it. , although it’s connected to Garmin Connect. 

  • I am not sure if this is related but I have a iOS app that will sync to multiple devices via Garmin Connect and iOS SDK. I have an old 945 paired to Garmin Connect (not actually connected anymore…it has been retired) and an Epix Gen 2 that I currently use (always connected).

    When receiving messages via the phone app (via receivedMessage), Garmin Connect inconsistently incorrectly identifies that the 945 sent the message causing the application to fail as it cannot connect to the 945 because it isn't connected (or turned on). I can tell this when debugging by looking at the device UUID that is sent back via the app: IQApp parameter - it references the 945 UUID. The message is sent by the user from the app on the Garmin watch, so I know what device it originates from.

    It doesn’t happen consistently. I have tried several approaches to determine what is causing: killing iOS app, killing Garmin Connect, deleting devices and reinstalling  devices in my iOS app via Connect. But, I have not been able to determine cause. Seems like a Garmin Connect bug.

    If there are thoughts this, I would welcome the feedback.

  • This device switching is maddening!  As an app dev, I have multiple test devices and when testing settings, it now requires going back 2 pages from settings to the device screen and then reselect of the original device I'm testing and back to the app settings anytime I switch the phone to another app and come back to Connect IQ app.

    Please fix ASAP!  This is wasting a lot of our time.

  • Still happening on latest update.  How F-ing hard is it to fix this?!  

  • It switches watch everytime I return to the app. I have two watches connected to my phone. If it is the wrong watch, I return to phone start screen and then back to the app and the correct watch is now selected.

    It's been like that a long time and it is very annoying.

  • Still a problem as of 2.27.1. 

    “Connect IQ Store is constantly working to improve your experience”

    [citation needed]