This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

I keep getting Express.exe error when I shutdown PC (v7.4.0.0)

As per the previous thread that now has been locked:

The error sadly persists - just witnessed it myself after I updated to v7.4.0.0:

The funny thing is - as per the above screen - I've not seen it for quite some time...! It only cropped up today, immediately once I updated GE to the latest version (v7.4.0.0) and logged out later.

  • I am on V7.4.1.0 and this has been happening since the 1st Feb.

    The garmin logs show nothing.
    The event view shows

    Application: express.exe
    Framework Version: v4.0.30319
    Description: The process was terminated due to an unhandled exception.
    Exception Info: exception code c0000005, exception address 56ADB522

    It doesn't happen every time. I had charged my watch from the PC earlier in the day but had closed me PC down prior to this session. The window produced says it is trying to access a location that is is not allowed to read.

  • Same problem last few days V7.4.1.0. Error pops up every time I reboot or shut down my PC.

  • The update keeps GE running in the background as the default setting.  Have you tried unchecking this in Settings (cogwheel). This has worked for a number of people with your problem.

  • You keep banging on about this in every second thread...

    If GE does not run in background then those who regularly connect their devices will not be able to sync them without launching GE manually. Putting aside lack of visibility of new updates, maps etc.

    I'm sorry but it's 2021 and it's just inconvenient (to say the least) - nothing under normal operation should force users to disable start-up / background run.

    So I'm sorry but its a bodge, not a solution.

  • The process is trying to access data that it is not authorised to use when the process is closing down. Has someone hacked your systems and introduced malware to the code?  Accessing data outside the stack is one way viruses like to work.

  • Same for me, 're this error and am wondering if it's now related to my 410 workouts sync issues I've been having since updating GE

  • I was getting the error with &, but now, after updating to so far I haven't got the error on shutdown (I've just restarted my computer 5 times in succession to test). I'll get back if I see the error again, but so far the error seems to be fixed.

  • I am running and still get that error whenever I shutdown - running Windows 10 professional.  

  • Sorry, I spoke too soon. I have just got the error "express.exe - Application Error The instruction at 0x0000000056E35D4E referenced memory at 0x00000000000000BC. The memory could not be read. Click on OK to terminate the program". I don't get the error every time I shut down my computer. After reporting the issue to Garmin I received an email from them on the 16th Feb "We have added you into an open investigation which will be used to determine the cause of this issue which we are looking into currently. Using the information provided they will test and reach a suitable resolution which will then be supplied to you directly by email. We cannot provide a time frame for this process as it depends on what is discovered during the investigation and what is required to resolve the issue. Any updates will come to you directly via email as an affected user of this case.". I have not heard from Garmin since. You'd think this problem would be easy to fix as it did not happen in versions prior to

  • My PC has been fine for a few days and the latest windows patch was applied this morning and on shutdown the error occurred again. Are you working on a solution or just ignoring the problem.