WMI Host Provider high CPU when running Garmin Express

This was also reported in the thread about GE using 20% CPU, but I thought the WMI-specific issue should be highlighted in its own thread. The problem was also reported in the Forerunner 945 forum. I had been trying to figure this out for a while until I saw that post. Sure enough, quitting out of GE made the high WMI CPU usage stop.

GE 6.19.3.0

Parents
  • For what it's worth: I observe exactly the same problem on my PC. Spikes are not that huge - usually sit within 10-15% - as per the below.

    The gap shown in the above presents the period where Express has been shut down and removed from the task bar / notification area.

    Further screens (via courtesy of Process Explorer):

    And that's what Process Monitor shows - it's running in circles with the same content on and on as far as I can tell.

    This is both latest Garmin Express and Windows 10 1909 (with no funny tweaks applied to the latter).

Reply
  • For what it's worth: I observe exactly the same problem on my PC. Spikes are not that huge - usually sit within 10-15% - as per the below.

    The gap shown in the above presents the period where Express has been shut down and removed from the task bar / notification area.

    Further screens (via courtesy of Process Explorer):

    And that's what Process Monitor shows - it's running in circles with the same content on and on as far as I can tell.

    This is both latest Garmin Express and Windows 10 1909 (with no funny tweaks applied to the latter).

Children