This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

CONFIRMED FIX - Garmin Index Scale (For my home network)

After reviewing and trying what has been suggested - nothing worked for me. 

I was able to pair and see network traffic passing, however, no data was being uploaded.  

My network leverages DOH for DNS. I turned off DOH for the Index Scale and I am now able to sync with Garmin using traditional DNS.

I‘m unclear/confounded as to why this “fixes” the problem - Garmin could best answer that  

  • I received a reply back from Garmin on this case. I still have not received any firmware updates to the device - still on 3.1. 

    Garmin has indicated that the device needs to be replaced. Although my scale is 2 years outside of warranty, they are replacing it with an S2. 

    I‘d suggest calling / emailing at this point to see what they can do. 

  • No idea what firmware mine is on, but I just spent the better part of a day trying to get this thing working again.

    It WAS working previously, but for some reason recently stopped connecting to the wifi, I assume they pushed an update that b0rked it.

    instructions provided with the device and app are terrible, so here's what worked for me (hope it helps someone out): 

    pairing mode

    1. to put the indexs2 scale in pairing mode, just press the reset button (once) on the back of the scale

    factory reset

    1. to factory reset the indexs2 scale, press and hold the reset button on the back of the scale until the red cog appears in the bottom left corner of the screen

    network router settings:

    1. 2.4Ghz wifi only (it doesn't work on SSIDs that operate on both 2.4 and 5GHz, so you might need to setup a separate network just for this precious little thing)
    2. If you use DoH DNS, it only works with Google DoH DNS (it doesn't work with Cloudflare DoH DNS)
    3. Wifi security needs to be on WPA/WPA2 (it doesn't work with just WPA2, only the WPA/WPA2 setting)

    setup of wifi network with Connect app:

    1. select manual entry of network ID (it can pick up my neighbours wifi from across the street just fine, but can't see the 2.4GHz signal I made just for it, spewing out of my router sitting right next to it)
    • note: dont waste time trying to update the password on a network you already setup with the device, it won't save the changes. just remove the existing network from the app and add it again as a new network.