This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

WiFi Password Not Being Accepted During Set-Up

My Garmin Index Scale will not connect to my home Wifi network.

During set-up the Garmin connect app prompts me to enter the WPA2 password, which I am definitely entering correctly. It then says the the password is incorrect!?!?

I am using the Virgin Media Hub 3.0.

Can anyone help me please!?

Thanks so much.
  • Also still having this issue, have tried with 2 different brands wi-fi routers, and 3 different APs from enterprise wifi.  None of them would connect no matter what settings I added.  The only thing that worked was connecting to my phone's wifi AP.  Scale is on version 3.2.  I don't know what they screwed up with this update a month ago but its absolutely terrible, was working perfect for YEARS and one unwanted update later I can't connect to my Wi-Fi.

    Even lost about 30 days of stats as I didn't actually realize it had lost connection.  Garmin, please fix this.  If you can't figure out how to fix it, just pull the latest releases that caused the problem and let us roll back to the old firmware.

    fwiw location is Japan

  • This is such a trainwreck.  I randomly had this issue after years of the scale working.  Then SOMEHOW i get it working for a month.  Then randomly it stops again.  This is so damn frustrating.  Any help from anyone???

  • The same for me. After firmware update I cannot connect to WiFi. WTF Garmin! 

  • It is frustrating! I don't think I've gave an update for a while and I know there's been a few other comments since then. But since they pushed out an update that caused my scale and other scales to stop working, I gave them a call about it for them to see if they could fix it. They did attempt a fix, but the fix was to go back to the older version that was "working." It didn't work, however I was then able to go to the hot spot on my phone. I was happy I could at least make it work that way though home Wi-Fi would be preferred. Though now it can't get on to my phone hotspot anymore. Not that I get an error, but it continues to try to sync but never happens. At this point I think I might give up for quite some time. I did not realize the scale was so low on their list of things to work on for their customers.

  • Mines still soft bricked. Haven't bothered with it, really annoying!

  • Garmin - it's not funny - do something with this bug if U wanna be competitive to others

  • Same issue here. Since 19. Feb no synch and not able to connect to home WiFi anymore. Tried everything but unable to get it to connect. "Invalid passord". Even if I remove the wifi password it ask for a password... This is the worst firmware update ever...

  • very frustrated.  same issue as the others.  try to choose a network and it says taking too long to connect and wont connect.   will connect fine to my phone hotspot though.   on v3.2

  • Same problem, upgraded my providers box, now s2 incorrectly claims 'incorrect password' . Just updated s2 firmware, no improvement. Fortunately I have a second (legacy) WiFi network with which it works, but I really way to retire this router. Come on Garmin!