This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

WiFi Password Not Being Accepted During Set-Up

My Garmin Index Scale will not connect to my home Wifi network.

During set-up the Garmin connect app prompts me to enter the WPA2 password, which I am definitely entering correctly. It then says the the password is incorrect!?!?

I am using the Virgin Media Hub 3.0.

Can anyone help me please!?

Thanks so much.
  • I'm in the UK, don't worry I'll Google it tomorrow. Thanks for corroborating my issue.

    Interestingly enough, when I connect it to my phone hotspot it works perfectly. I have reset the router completely, turned it to 2.4ghz only, turned it to both 5+2.4ghz. Changed all the settings I could think of and even given it its own static IP address. Nothing works. I've tried as well to create a guest network. Tried using no password and a simple password. Tried using a complex password on my phone and it worked so it's not complexity. I have tried resetting the scales. I have tried restarting my phone. I have tried clearing the data from the Garmin app. I have tried reinstalling the Garmin app. I have tried new batteries.

    The only thing I haven't tried is using someone else's router to see if it works. I'm tempted to take it to my friends house to see if it will connect.

    But what I will say is, I weighed myself right before I did the update because I wanted to see if the update would have an effect on any of the stats. It synced fine. Then I update and it wouldn't connect to WiFi. I went to settings forgot WiFi, readded it and now its f***ed!

  • I'm in the UK,

    Just go to Garmin Support

    Then Chat, Call, or Email

  • Yeah, it's frustrating. I spent a lot of time trying to do a lot of what you did as well. My mobile hotspot works when I do a test connect, but when I try to genuinely connect it to use it, it doesn't work. It just gives me my weight and no other data.

  • My Garmin Index was working like a charm for several years. 
    But 22 feb 2023 it stop connecting to wifi. 
    (i belive around this time i press update on several Garmin products i own)

    it would not Connect whatever i do. 
    password was for shure correct.

    So i went desperate thinking Garmin hade software updated the index to not be compatible with my unifi network any more. (Yes, i have separate 2.4 wifi for devices like this)

    So i found a several year old asus rp-ac52 repeater i was having in «old stuff box» and added to my network as a separate AP.
    garmin index connected flawless to that one.

    so my conclusion is that Garmin have for some reason broken the software in it, making it not compatible with some networks.

  • Hey everyone! I got an email from Garmin yesterday in regards to the ticket that I submitted about the whole Wi-Fi issue. They say that they created a new software update that was released yesterday that they think will resolve the problem. I have not got around to doing it yet, but just spreading the word to my fellow Garmin index users!

  • Thanks for letting us know Mark! Will update tonight and see what happens.

  • I suggest you don't update because it's made it even worse. Updated to 3.11.0 or whatever and now it won't even connect to the app. It just tries to connect flashes up the Garmin connect logo and then reboots and does the same. Can't access the scale function at all because now it's stuck in this stupid bootloop scenario. Well done Garmin!

  • My index s2 scale was not able to finish wifi setup after last software update in the end of Jan 2023. I managed to get it working today. Below are what I did.

    1. Set up the s2 to connect to my phone hot spot. This allows s2 to update its software. The update took a while so I just left hot spot on.

    2. I checked back after about 1 hour, the update was done. I verified that s2 was now able to sync data via hot spot.

    3. Finally set up the s2 to connect to my home wifi. No more dreaded 'incorrect wifi password' error.

  • I had the same problems, with endless attempts to join the wifi network and then failing at the password. I resolved it by setting up a guest network on 2.4mhz only and then switching my phone to the guest network The scale immediately found the guest network and accepted the password. All working fine now, but what a hassle.

  • Was that with the latest update?

    The update has bricked my device essentially sticking it in a bootloop. I have to contact Garmin or Amazon but I haven't yet because of the hassle

    Even creating a guest network didn't work for me and other people's before this update.