WiFi Password Not Being Accepted During Set-Up

My Garmin Index Scale will not connect to my home Wifi network.

During set-up the Garmin connect app prompts me to enter the WPA2 password, which I am definitely entering correctly. It then says the the password is incorrect!?!?

I am using the Virgin Media Hub 3.0.

Can anyone help me please!?

Thanks so much.
  • I have the same problem. I have had my scale for a few years and never really had any problems. Just recently a new software update came and I did that. Now I can't get connected because it says in correct password. It is frustrating.

  • I have the same issue! I have had my scale now for a few years and no real problems. Recently I got a software update on my scale and now I can't connect because it says incorrect password. I have done everything and even chatted with Garmin online, and still no luck. It's very frustrating.

  • The same problem after update to 3.0.xxx

    - can't connect to the HFC Arris router (previously worked fine). 

    - can connect to teh samsung galaxy S22 hot spot

    Already tested with AES , TKIP and open wifi mode - the same result ... wrong password (even with open network!!!)

  • I gave them a call and the man said he would create a ticket to get it looked into. He was hesitant in doing so because it sounded like it would be a lot of work on their end. I think it justifies it because it's their own product that they should be looking into. Did not get a ticket number though as I had to leave because I had a meeting to get to lol. They said they received no calls about this issue and that contributed to his reason and thinking it wasn't software update related (which I guess could still be the case); so maybe if more people gave them a call, informing them about it, it would raise more flags and possibly make them a little more comfortable to look into it.

    Like you, I was able to get it connected to my phone's hotspot.

  • Are you sure both wifi bands are still enabled, 2.4 & 5 ghz?

  • I think I have only the 5. I can choose to split my bands to have both 5 and 2.4. When I do, I see the message that says this is not recommended. I didn't change anything on my end though. It's been this way for a while. Only when I did the software update did I now have a hard time trying to get connected.

    On a different topic, the engineering used to implement the update is a little excessive. You have to take the batteries out while pressing and holding a button titled "reset." Thinking

  • Having exactly the same issue after updating the scale today. Wish I'd never got the email explaining how to update it. It was working fine before.

  • Everybody who is having this issue after the update needs to call in. I think I was the first one to call in and the guy had doubts that the update had anything to do with it. He said something along the lines of "this isn't a known issue. I've never heard of this before." Granted, this was a day after the update so it would make sense. The more people who call in will help bring this issue to light.

  • What's the number mate I will give them a bell tomorrow?

  • U.S. 913-397-0872 or 1-800-800-1020

    Canada 1-866-429-9296