This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Garmin Swim keeps resetting and now won't allow pool size to be input correctly

My 15 month old Garmin Swim is on the blink. It keeps resetting itself at random times and it is not not allowing me to input the pool size rendering it quite useless. When I select 50M pool, it says pool size 0 selected. Further, the blue swim button is no longer bringing me into the swim function. any thoughts?
  • Had the same problem here. First, the “light” button stopped to work, then the watch started to flash the”please wait...” sign, and finally the clock stopped working at all. I replaced the battery, made the initial settings, but the only thing I couldn't configure was the size of the pool, which always showed the number zero. I tried to delete all my data records, but it also didn't work, the number zero kept showing up. I was only able to set the size of the pool when I forced the clock to reset to factory settings (Press and hold MENU, CLOCK, and UP simultaneously. Select YES when prompted.)

  • Same problem, can't believe Garmin is ignoring this thread for years. Won't be buying another Garmin

  • August, 2020, have my Garmin Swim since 2016 and now it's starts to get trouble, no sync with PC and fails to save my swims. Allready do it a hard reset... 

  • Probleam disapeared after putting the battery off and on.

  • Thank you . I was facing the same symptom and your suggestion to perform a factory reset has fixed the issue. I can now set pool size on my Garmin Swim.

  • The reset worked for me have had my original Watch for 5 years but it developed a leak and the strap also disintegrated bought a new strap but clearly water was getting in so acquired a replacement form ebay had the Zero pool size problem. So came here tried the factory reset and hey bingo it worked also this enabled it to connect to my Ant Stick as the ebay one didn't come with one.

  • I have another thing people can try after the master reset - Set both Time 1 and Time 2!  I'm not sure why this would matter, but also each of these has it's own date including year.

    I have two watches (one my daughter stopped using and gave me) both of which had this issue.  I was trying various things mentioned in this form and on one of them when i set it, for some reason it came up to setting Time 2 instead of Time 1.  I set that and then realized it was on Time 2 so i set time 1 (which was on like 2069 or something) and then was able to set the pool size.

    On the other watch i had set Time 1 only and was doing various combinations of master reset and syncing, none of which worked. Finally decided to set Time 2 after which i was able to set the pool size.  YMMV