This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Garmin Swim keeps resetting and now won't allow pool size to be input correctly

My 15 month old Garmin Swim is on the blink. It keeps resetting itself at random times and it is not not allowing me to input the pool size rendering it quite useless. When I select 50M pool, it says pool size 0 selected. Further, the blue swim button is no longer bringing me into the swim function. any thoughts?
  • Have you tried a factory reset? Press and hold MENU, CLOCK, and UP simultaneously. Select YES when prompted.

    If it's been 15 months, I'm wondering whether you have changed the battery?
  • Have you tried a factory reset? Press and hold MENU, CLOCK, and UP simultaneously. Select YES when prompted.

    If it's been 15 months, I'm wondering whether you have changed the battery?

    Yes, replaced Battery and completed a reset. still no joy!
  • Darn! I'm curious, did you replace the battery THEN start having the issues, or did you start having the issues and then replace the battery?
  • Same problem...

    I had the same situation with my Garmin Swim: spurious resets and no way to set pool size different than 0. I replaced the battery for a new one and the error persisted. I then reset the clock and the error persisted. I then forced a transmission to garmin connect (even with history log empty). After that I was able to set the pool size back to 25 meters. I'll try next Friday to see if it really works on the pool.
  • Another option to try is a Factory Reset. You will lose your History and Settings, but there aren't very many Settings on this watch anyway. Here are the instructions for a reset:
    1. Hold the CLOCK, MENU, and UP buttons simultaneously.
    2. Select YES when prompted.
  • I have same problem and no luck even replace new battery and master reset a device.
  • Can you provide a bit more information? How long have you had the watch? How many times have you replaced the battery? When did the problems start relative to the last battery replacement and were you prompted to replace? And is the issue you are seeing exactly what is described in the title - keeps resetting and you can't enter the pool size?
  • Just a few pieces of information for me:

    I've had a swim since basically launch. Replaced batteries twice after being warned of low battery (I think I get roughly 9-10 months per battery)

    Last night I heard some odd beeping on and off from my countertop, I assumed it may have been my swim watch, but when I checked it I didn't see any warnings or low battery indication.

    This morning while swimming I noted ~20 minutes into my working the watch had reset and was asking me for Language.

    I assumed the battery must have died and didn't use it the rest of the workout.

    After my workout I replaced the battery with a new one, my open circuit battery voltage was 2.78V (I should have applied a load to it, but I didn't care, I trusted it was at the end of life anyway).

    After replacing the battery I setup my time and weight, etc... but noted my pool size wouldn't set -- all sizes reported 0 back. 0 yds, 0 meters, even 0 0/0 yds (33 1/3 setting). Similarly my history showed really wrong dates, I think the history was in 2038.

    I tried a master reset as noted (Clock + Menu + Up) and it appears to have fixed my problem -- my pool size is set now.

    I will post further if something comes up next time I try swimming with the device.

    A little disappointed I didn't have a persistent "low battery" alert or icon before all-out dying.
  • Thanks for the additional information. FWIW, there usually are a few levels of low battery indication that you would have to ignore (warnings if you press light or enter swim mode as well as a little icon at the top of the screen that comes on) in order to end up losing a workout like you did. I don't know what happened in your case.
    I'm glad you seem to be back up and going after the master reset.
  • I'm experiencing this problem too. My Garmin Swim is +2 yo so warranty is over.

    From time to time, I'd start a training session and in the middle of the lap, the watch resets itself and then I can't enter the pool size anymore. Just like what was explained in the 1st post, I choose 33m and the watch keeps going back to 0m. No matter what I do, it won't let me set the pool size.

    After a few hours out of the water and factory resetting the watch, sometimes the problem is temporarly fixed. Then it'd happens again. The battery was replaced 6 months ago and there's no low battery signal showing up.