This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

No Satellites Found after GPS Firmware update 2.50

After some times (years actually) of smooth-less rides I had the bad idea of updating the maps.

together with the maps I apparently also got an update of the GPS firmware to 2.50. I started the Garmin and I had a screen advising about the update process, then the confirmation that the installation was complete. and the same notification on and on every 30 secs. meanwhile, no satellites found. 

I reset the Garmin, the update complete"message disappears but still no satellites.

after that I've tried everything I found here in the forum for other models (mostly 530) with no success Disappointed

Can you guys help me to have my riding mate back? Slight smile

Edge Explore 820

Software Version 12.70

GPS Version 2.50

TSC Version 85.22.00

Thanks all!!

  • I brought it today with me on the way to work starting a new activity leaving home and it got a new GPS fix on the way, but then the signal was lost.

    elevation is calculated.

    system finds a lot of satellites but apparently it’s just not able to fix the position (currently it sees 12 satellites in GPS+GLONASS mode). Tried to change to GPS and Galileo but can’t appreciate differences.

    any idea?

  • For me the intermittant GPS signall loss smells to a hardware failure...
    Maybe worth to try if the misbehavior shows in all profiles? Guess it does, but think of it because GPS is forced to OFF in the INDOOR profile. Maybe switching On and Off manually pulls the trigger?

  • Yes, that’s the same behavior in all GPS profiles 

  • I did'nt mean GPS profiles, but activity profiles like Train, Ride, Indoor, etc.
    But weird it is not getting a GPS fix with so many registered satellites.

  • Tried to do so. At certain point it got signal and it tracked around 1 km. Then signal lost again Disappointed

  • Something really strange is happening here.

    yesterday slowly slowly signal was catching up: during lunch time some intermittent signal with quite a low precision (just few satellites fixed just for few minutes) , in the afternoon quality was becoming better and better till evening when the lock-up of satellites was immediate with excellent coverage in all profiles, with or without phone connected and also after switching off and on again the device. tracking accuracy at 3m.

    I thought all is ok, very happy on the outcome.

    Today, tried again I see the satellite constellation but zero fixing. what can be still wrong here?  :( :(