This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

No Satellites Found after GPS Firmware update 2.50

After some times (years actually) of smooth-less rides I had the bad idea of updating the maps.

together with the maps I apparently also got an update of the GPS firmware to 2.50. I started the Garmin and I had a screen advising about the update process, then the confirmation that the installation was complete. and the same notification on and on every 30 secs. meanwhile, no satellites found. 

I reset the Garmin, the update complete"message disappears but still no satellites.

after that I've tried everything I found here in the forum for other models (mostly 530) with no success Disappointed

Can you guys help me to have my riding mate back? Slight smile

Edge Explore 820

Software Version 12.70

GPS Version 2.50

TSC Version 85.22.00

Thanks all!!

  • Supposing the GPS chipset in the Edge Explore 820 is identical to the one in the Edge 820 you might try to re-install the GPS chipset firmware 2.50. See:

    You will find a download link and a description where to place the .gcd file. At your own risk of course...

  • Thanks! 

    the system indeed sees it as an update and installs it, but unfortunately still no GPS signal Disappointed

    any other trick before trashing it out?

  • Is the remoteSW folder empty now? If not, delete all files and sync with Garmin Express. Express will not tell you that an update is available but maybe it will supply a new GPS 2.50 update file. Restart the unit and see if 2.50 is installing.
    One other trick that is described in the link I gave you above is editing the GarminDevice.xml file to trick the update system you have an older chipset version. I suggest to edit the minor section to 42 (was 50) and repeat the sync procedure with Express. Again... for desparate people only...

  • Yes, remoteSW folder is empty.

    let me do the desperate move....keep posted :) thanks

  • If the 820 is still alive but only does not find satellites...

    Does the 820 have an option to switch the GPS mode to - for example - GPS only or GPS + Glonass or GPS + Galileo? If yes, try to play around if switching this setting will help to kick-off the satellite search. I'd start with GPS only.

  • Desperate move doesn’t help. I changed to 47 e other numbers but then it goes back to 50 at the first sync.

    yes it goes have GPS Method selection, I’ll try playing around. Not much optimism…

  • 820 is totally alive. Everything works great including pairing with iPhone. “Just” doesn’t find any satellites Disappointed

  • I see you are working with Apple? Did you empty 'trash' (Windows terminology) because maybe there are some files left in the hidden trash bin on the device?

    just my 2 cents...

  • Something bizarre happened overnight.

    I left it outside all night long with a running activity requiring GPS signal. Map was centered somewhere in USA, clock was USA time.

    I got this morning back still active (2% battery) again with no GPS signal but:

    1. Map was centered in Europe exactly where the Garmin was placed.

    2. Clock was adjusted 

    3. system says “GPS signal interrupted” while before was “acquiring GPS Signal”.

    so apparently it got a fix to the satellites. 
    any idea?