This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Garmin navigates to start and provides 'distance to next' but after start does not give further navigation prompts

When I choose to follow a pre-planned ride and opt to 'navigate to start of course' it does so with no problems providing me prompts and 'distance to next' on the data screens.  As soon as I go past the start and actually get on the pre-planned route all navigation prompts stop and the 'distance to next' is blank.  The only way I can follow the route is to stay on the map screen and follow the highlighted route.

Please help! 

  • I have exactly the same problem. Anyone had any joy solving it?

  • Not yet. Garmin has opened a case for me, and I sent them data from my 820 that they requested. Consider contacting them, maybe more data from another device will help.

  • My Edge 820 Explore quit navigating after last update.I did it 8.29.20. The courses I tried to use have worked in the past. I have to turn battery saver off and follow course line. The entire time I'm using it a line across the top of the screen says "OFF COURSE" when I can clearly see I'm on course.

  • My Explore 820 quit working after the last update. No turn by turn navigation, just prompting "OFF COURSE". Just got off the phone w/

    support, Tech admitted they broke it. Reset some stuff until new "UPDATE" comes out. Supposed to make it work. 

    -Home screen


    -Saved courses

    -3 Bar menu at bottom>course options

    -Make sure turn guidance is on

    -Turn off  Off course warnings( This is where the problem is).

    -Back up to home screen

    -Three bar menu


    -Activity settings


    -Routing>Calculation method>Minimize distance

    -Back arrow

    -Navigation prompts>Text only 

    -Back to home and done

    Hope this works ,I will be trying it out later. PEACE.

  • Seems to work so far, thank you! 

  • Thanks for posting. It doesn't seem to work for me, the Distance to Next is always 0, elevation map is flat-lined. I can, however, make step-by-step and distance to next work the first time I use a Course after transferring it to the device. 

  • Tried it on a proven course and it still doesn't work. Still says "OFF COURSE". So much for that. Time for another phone call.

  • Well, made another phone call to Garmin and they analyzed some of my rides on Garmin Connect. I tried to explain that some of my courses I have used before with no problem. I told him the device worked fine until the last update, he said that this was probably a coincidence. When looking at my rides using a course they said the GPS was working correctly. I told him I know it was working because I could see the course route and the icon showing where I was at. No turn by turn and it tells me I'm off course. It will navigate to the beginning of course then it stops. They want me to go out and try one more thing then call them back again. He said they won't open a case yet. Would have to go through with a total reset first. Also mentioned device replacement,but mine being way out of warranty...$$$$. I'm wore out.

  • Well, that is a bummer. When I did the chat with Jason, he also tried to tell me it was because my device is old, and I'm sorry, but I'm with you, this broke after the last update. 

    Mine behaves exactly as you have described. Jason did open a case for me. It is << Reference ID:17528351K1 >> Case Information <Q#:1000060>. If you are going to call back after trying that one more thing, please feel free to reference this case number.

  • We are aware of this problem and actively working on a resolution. I apologize for any inconvenience this has caused. I will provide a update or notification of a new software version when one is available.