This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Edge 820 - Navigation only partially working

For quite some time (I can't even remember when it started) I have the problem that the navigation of my Garmin Edge820 stops working after some time.
Sometimes it is after 10 min, sometimes after 1 hour ... it is undefinable.
The 820 then show a quite random navigation instruction on top of the map which does not change any more for a long time.
This can last, again for an undefinable time, after which, sometimes, navigation resumes and starts working again, or it never resumes.

What I see is a random instruction on top of the map, no white arrow indicating turns any more on the map itself and no more beeping sound when a turn approaches.
The route itself is indicated correctly on the map, so it is possible to follow the route but without any navigation instructions. This is annoying, especially while mountainbiking.

Another strange thing is that, while navigation instructions are not working, and taking a wrong turn, the edge820 warns me being off course, gives me navigation instructions to get back to the course and once on the course, the wrong navigation instructions is displayed again and navigation stops giving instructions :-(

I have this with all kinds of routes: gpx from Strava, from Komoot, from other sources but also with routes created on the device itself by making a route of a previous ride.

What I have tried:

  • upgrades, downgrades (e.g. when suffering from the 12.60 upgrade navigation problem)
  • removing all courses and importing them again
  • removing profiles and importing them again
  • when the navigation fails, stopping the navigation, rebooting the Edge820, load the route again and exactly the same wrong instruction appears again, navigation still not working
  • ... and offcourse sending a mail to Garmin support with no result yet

Anyone any suggestions ?

Could I have the wrong or too many maps active? I have only standard Garmin maps on the device:

  • INTL Standard Basemap, NR
  • Garmin Cycle Map EU, North East, 2020.10
  • Garmin DEM Map EU 2017.20
  • Garmin Geocode Map EU 2020.10
  • Garmin Cycle Map EU, South West, 2020.10

Thanks in advance for any help !

  • I know this is an old post, but do you or anyone else have a solution for this annoyinf issue?

  • I don't think this is still an issue. Mine has been working perfectly for the last several years on s/w 12.70

  • Hi, it is definitely still an issue.

    Mine has the same odd behavior, I turned off turn-by-turn navigation. Then I can have at least some correct track following.

    Furthermore, route calculation takes forever.

    I did some tests years ago, see thread:

    Maybe that helps a bit.

    But I fear, there will be no solution for this issue.

    @nickdodo: If your's is working, please let us know your configuration: firmware, navigation settings, sensors, maps, ..

    Help is very much appreciated

    Thanks Harry

  • Hi HarryG

    A couple of things -

    1. I can navigate while it is still calculating. If I start a route I can ride and get  directions before it finishes calculating. I usually just start and ride and everything is fine.

    2. Do you live in an urban environment? City or large town? I have know people have problems when there is a high density of roads, cycleways etc.

    I usually use plotaroute to plan my routes (usually from 50 miles to 100 miles but some longer. I use TCX and reduce the number of points to about 1000 or less. Turn bu turn works fine.I have used routes (GPX and TCX) supplied by others and I've never had a problem.

    I usually ride in the UK but I've not had problems with routes in France, Main land Spain, Mallorca, Gran  Canaria, Italy. There may be other places - I don't recall.

    I have the background light at 0% and use a HR monitor, Power meter and Di2 - all on ANT+ 

    I don't use the reroute function - but it pretty soon tells me if I've gone off route. I then look at the map to decide how to get back on route if it is not obvious that I missed a turn or took an early turn.

    I seldom have the map page displayed and it pops up when there is a turn.

    I did have problems with some of the earlier issues of software - particularly if the course was lost and rejoined or even if I stopped for coffee and turned the unit off. Now this all works fine with 12.70. Just turn on - press start and start cycling.

    I hope this helps a bit - I've had my Garmin 820 since 2016 (although early item replaced under warranty) and think its brilliant - perhaps a bit short of battery.


  • Hi Nick,

    thanks for the update.

    Seems we have the same setup and situation, I'm also on a replacement as in my first 820 elavation was corrupt afer a year.

    The sensors are also the same, Garmin Vector, HR + Cadence

    I'm living in south of Austria, Graz. The problem with cities I could already resolve by starting the routes a few km outside city. But in turn by turn mode, it alwas get's stuck on first or second navigation hint. I also have recalculation turned off.

    Maybe I'll try once more a factory reset, but I do not have much hope as I tried out almost all firmwares.

    Thought already about a new one, but the 40series with the Garmin pricing....

    Best wishes


  • I've just taken a look and I also have,

    Default ride type = Road

    GPS Mode = GPS + GLONASS

    Routing Mode = Road Cycling

    Calculation Method = Minimize Distance

    Lock on Road = off

    Recalculation = Off

    Avoidance = all turned off

    Navigation Prompts = Map

    Best of Luck.

    I like mine so much - I'll only upgrade when it dies.


  • The only difference was "Navigation Prompts = Text" on my side

    I'll check on the weekend, but would be really odd, if that's the cause


  • That would be odd. 

    Best of Luck


  • Hi,

    had no luck with the issue.

    Even did a wipe (deleting all files) and factory reset, but was always stuck in route calculation and never gave a hint on upcoming turns.

    BTW, route was only 300 points and starting outside the city.

    Since the battery is now pretty dead, too, I'll go for a new device (but probably an old ..30 series :-) )

    Nevertheless, thanks for your help


  • The only other thing I can think could be a problem is the map.