This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Edge 130 Cold Weather Performance

Today’s ride was cold - around 11 F (-12 C). My Edge 130 worked fine for the first 30 minutes and then started automatically shutting down. I could restart it (once I noticed it had shut down), and when it restarted it knew I was still in the middle of a ride, but no data was saved between shutting down and restarting. Once restarted it would collect data for a minute or so before shutting down again. After futzing with it a number of times I gave up and resorted to the Strava app on my phone which worked fine (phone was in my inside coat pocket).

Garmin’s specs list the temp range of the 130 to be -4F to 140F (, so I would expect it to work normally at the temp of today’s ride. I suppose I could ride with it in my pocket to stay warm, but that shouldn’t be necessary given Garmin’s temp specs.

Has as anyone experienced anything similar on your device? Is there anything I can do to avoid this happening again?

Thanks in advance for any advice.
  • Does it have something similar to the 'extended display mode' for triathlons? Also, I think people enjoy the affordability of the older edges now...I picked mine up w/ a bad battery for $30

  • I ran into the very same issue with the 502530 I got. I wonder how others were not having this issue. May be those 502530 batteries were thinner then the specification. Mine was 4.8mm thick.  I didn't want to force the PBC down to make the buttons work when I saw that the connector on the PCB was already making a mark on the battery. The LiPo batteries are quite volatile and don't want to risk damaging it.

    The other issue is that the original battery is high voltage LiPo going up to 4.35V. It appears to be difficult to get them in these sizes. It looks that the Edge 130 charges up to about 4.30V and stops right after that which is not helping the longevity of the 3.7V LiPo, but probably still OK. After disconnecting the 130 from the USB port and letting it run a bit the voltage quickly goes back to 4.1V. Since I could not install the 5mm thick battery I ran a few tests with PCB and USB port put back in and keeping the battery outside a case.

    Unfortunately the 502530 battery I have doesn't seem to have over voltage protection as with the hobby charger in high voltage LiPo mode it went up 4.35V without getting disconnected.

  • I also put a bigger battery into it, following djbahool instructions and unfortunatelly I also have issues with side buttons. Not working when tryin to push it with a finger, so now I ended up using a 'tool' for pressing the button for an effect :-( I really like the form factor and features of Edge130, so I will use it untill it stops working and then replace it with something more appropriate.