This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Track run Workout bug and total distance off

I had the weirdest issues today during my track run.

This is after installing 14.13 and creating a new Workout using the latest Android version (ref the compatibility issue of Workouts).

I must clarify that all my track run's with selected interval workouts (very equal to this) have been working on all prior firmwares.

So there are 3 issues in this report - all found in one activity

1) Track run with selected workout: "Rest until lap button" step is buggy on the watch during my exercise

2) Total distance is 10k too much, and causes my speed averages to be of world class

3)  Sync to Strava is very buggy, and seems to have much worse/crazy lap data than the Garmin app

The Workout itself is very simple (


Warm up


    Run 1000m

    Rest until lap btn press

Cool down


After running 1000m this will (normally) trigger to "Rest section" and reset "lap-time"-field to 00:00.

It did today trigger to "Rest" as expected, but the "lap-time"-field on my 955 was restarted at random values like 02:48, 01:30 (I cannot remember all, but I then had to use this random start value as baseline and add 1 minute Rest time myself).

Usually it will (and should) start Rest lap time at 00:00 and I will press lap btn after my 1 minute rest and run on.

IIRC there were 2 times it actually started my Rest segment at 00:00 as expected.

This strange behavior also affected the total distance covered. It should be 15.6km, but ended at 25.6km (perfect 10k too much). Speculation here: as mentioned 10 out of the 12 x 1km repeats behaved buggy on pause segment, could these 10 add these extra 10km?

Anyway, Strava now think I'm the king of running, but after selecting "Correct distance" from the Strava menu, it magically corrected it to 15.6km distance (as was the correct distance). Luckily this removed my new Strava world records. The GPS segments are wrong, and laps are not correct (like 30sec/km stuff).

All instantaneous data on the Garmin web seems to be correct like pace and heart rate (over time). The lap overview on my Garmin phone app is also correct, 1km @3:58ish. But the rest of Garmin web/app stats seems to be wrong.

Correct lap data in Android app

A little too fast

I really hope this can be fixed, it's very stressful to do a workout and struggling with tech at the same time.





Update 14.02.23

Same thing happened again today, but this time I tried to use Structured repeats via the training Intervals menu.

The first lap failed in the same as my original post (added 1km to total distance and rest segment started at lap-time 6:53 instead of 0). So I stopped the workout and restarted as Open repeats.

This forced me to manually click the lap-button as "lap reset" on every 1000m, that did work as expected - it also seems ok in Strava, but the average speed is way off due to missing rest segments, so there is something fishy going on. Total time in Garmin is 1:03:01 (correct) and Strava shows total time 53:53. (failed with Structured repeats, I have manually deducted 1km from total here!) (Open repeats, with a strange Strava transfer) (the Strava transfer missing time from rests, giving me a overall average speed of 4:13 instead of 4:57)

I have not tried to use Time as lap-trigger yet, but we can conclude that Track-run using "Distance" as lap-trigger fails miserably, and transfer to Strava seems to fail either way in track run intervals.

Note from moderator: , the only reason your post keeps getting flagged is because of the links. All posts with 3 or more links get automatically flagged as potential spam and need to be approved by a moderator. Please try to be civil in your communication with moderators. Thank you.

  • I have very similar issue. My workout was 4 times of 3.2km run(target pace: 3:52~4:00/km) + 2 min jogging(Recover for 2 minutes without target in garmin connect app). Since auto-lap was setted to 400m, 3.2km running should be 8 laps. After finising 8-th lap, my laptime was weird. Normally, it should be around 1:34. But my watch say 8-th lap time was 12.9sec! And time for the subsequent recovery jogging was only 30 seconds.

    This problem continued to occur in subsequent repeat blocks. Even the last running lap time of the 3rd repetition block was recorded on the Garmin Connect App as 1193:01:05.1.

    I also had have no problem using workout in track run app until the update(14.13).

    1. Yes
    2. Yes
    3. Repulic of Korea

  • Had the same thing on track last night.

    1) Not showing interval pace

    2) Not showing recovery lap timer counting up from zero

    3) Nonsensically high total distance

    4) New records for all distances up to 10K

    5) Editing lap names within GC created complete garbage of all the interval distances and times

    Disgruntled is an understatement!

  • had the same yesterday. Counted about 10km instead of 6,4km (8x400/400m intervals).

  • I have very similar issue. Observed at least four times. I think the problem is how the device works with prepared workout and its single steps.

    • FR 955 solar (14.13)
    • Track mode
    • Preprepared workout

    My training (workout) had two sets of 4 kilometers of tempo run (target pace 3:35 - 3:45/km) and 2 kilometers of recovery run. Automatic laps were set to 1000 m. Everything was fine at the beginning of the training - I finished the first 4km section (the section was correctly split into 4 laps of 1000 m each - i.e. 4x 1000 m). and expected a recovery run to follow. However, instead of the recovery section, this section was skipped (it was ended, but counted as finished with the distance of 2 km) and the workout was moved to the next section of the tempo run. The same situation occurred in the second series.

    I've been using track mode for a long time and until the update to version 14.13 I had no problem with created workouts.

    I ask for a quick fix, because in the last months the updates are full of bugs and with each update new bugs appear.

  • Same issue here. Problem with track run workout since 2 weeks. The issue occurs in the transition phase so it is very impactful on interval workout cause you have many transitions between ryhtms, but it occurs also in the transition phase between the run and the cooldown, look at the picture 

    the last km of the run in 16s!! Great result

  • I had a similar issue in today's workout.

    • FR 955 solar (14.15)
    • Track mode
    • Preprepared workout

    My workout consisted of 15 sets of 600m tempo run (target pace 3:25 - 3:30 min/km) and 1:30 minutes of recovery time. Automatic laps were set to 400 m. A few seconds after entering my first recovery interval, the watch began counting down to start my next 600m tempo run. At first I figured that I was just too exhausted to "feel" how long 1:30 min. actually are. But right after my second fast 600m interval I watched the screen closely. It said:

    • Recover for 1:30
    • And then it jumped right to 25, 24, 23... Seconds. (Every recovery interval cut me short a different amount of time. Only one recovery interval was 1:30 minutes long).

    I am very unhappy about this, since missing recovery time really messes up the session. And for the next few sessions I will have my doubts whether my watch will be able to count the time correctly.

    Garmin, please fix this. The Forerunner is for runners and we runners want to trust our devices with basic training features.

    1. Yes

    2. Yes

    3. Germany

  • Today I had also similar issues. I had 4x2500m (increasing pace workout). 2nd, 3rd and 4th lap, Garmin worked as a time machine and moved me in 500m forward in one second. In result I ran 8500m, but it counted me 10000m.
    Garmin, come on, what is wrong with you? Make a focus on software development and stable software not for a new gadgets and features...

  • Hi Garmin,

    Please take note of this bug.

    I faced the same problem. I did a track run pyramid workout (400,800,1200,600m) with rest in between. All the rest stages was skipped and my distance was doubled from 3km to 6km, with an insane pace of 2min/km.


    1. Workout was set up in garmin and pushed to 955.

    2. Workout tried on garmin 245 with no issues.

    Please assist in checking this out.

  • Have you contacted support and logged this issue.  Please do, that's how we get things logged and hopefully attention to all the issues.

  • Same type of issues here. Thanks for your detailed description.