This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Can't select target using map to navigate?

Perhaps I am overlooking something, but when navigating and using the map to (try and) select a target this doesn;t seem to work with the 955...

With the 945 I see a crosshair and long pressing start allows me to navigate to the point in the crosshairs, but on the 955 there are no crosshairs and long pressing start doesn't do anything so I can't find a way to navigate to a target point on the map... anyone?


The watch was delivered with 9.12 sw, I received a 10.10 update and now this issue is fixed! 


Nevermind, I THOUGH it worked but I didn't actually start the navigation. When I do restart the watch reboots... so still not working. And now I also can't see the crosshairs anymore, so still a mess unfortunately

  • I needed to use navigation by selecting location on a map...the issue is still there in version 11.12. I don't get it. No crosshair, no start button options. This is more than a month old post.

    Various other bug fixes and improvements.

    Yeah right...everything but the important ones. My favourite description for apps updates - bug fixes. WHICH BUGS HAVE YOU FIXED:) This doesn't relate just to Garmin.

    Bought this watch mainly for this function (over cheaper FR255) and the function still does not work after 2 firmware updates. I thought Polar and Suunto were bad and slow with updates and fixes, apparently all of them are.

  • After turning the watch off and back on, there is a crosshair, selected location, Start - choose that POI and the watch restarted.

    Unfinished product in my opinion, like it was forced release + that Start button has "2 positions", the ghost one halfway pressed (like a shutter button on camera when focusing) and fully pressed that does something actually, already mentioned problem on the forum.

  • Ciao,anche il mio ha il tasto Start che ha 2 livelli di pressione.

    Per favore,come faccio a fare apparire il mirino nella mappa?Da che attività devo partire?Grazie

  • Newly purchased Garmin 955 with FW 11.12 concurs the same issue. Surprisingly this issue has not been resolved for more than one month and there is not much users complaining about it!

  • thanks for your answer. many users may not complain perhaps because it is not one of the functions that most interest them. For me, maps and navigation are important. You should have preferred a fenix7 for navigation but I prefer the size and weight of the Fr955. I really hope they sort things out a bit about it.

  • yeah, i reported it to garmin via support and they wrote to me that they dont know about that bug and that it isint there :D They asked me to record video from process. I will do it later :) 

  • Wonder what they'll say...

    Went through the same and in the end got a "oh, your device seems defective. Please send it in for a replacement."

    Yeah, screw that. Fix your software please.

    (And no response after saying that, in a much nicer way of course)

  • Exacly I don't know if I want to continue discussing with them  because I know the end of the conversation. 

  • Anyone who report this issue to Garmin representative,  please simply tell them that the watch doesn't operate at all according to instructions elaborated on Page 70 (Navigation) of Garmin 955 Owner's Manual.

  • maybe we should all send in our watches for replacement over and over again ( as it is a firmware bug) until they notice?