Battery drain after 6.20 update

My forerunner 945 was autoupdated overnight and since them am observing very high battery drain.

In about a 5 hour period (without any activities) it has drained from 88% to 24%.

Is anyone else experiencing any problems since receiving this update in particular? 

Thanks.

Christian 

  • WiFi off, pulsoximetr at night, ANT-connection is off, exсept of exercises time, watch face without second.

  • As another data point, possibly pulse-ox related.

    I experimented with switching pulse-ox on overnight, but didn't get much info from it and switched it off, but didn't remove the pulse-ox widget.

    I noticed that battery drain was still surprisingly high which is something I've not had a problem with before, and reboots didn't fix it, but after removing the pulse-ox widget (and yet another reboot) I'm back to the usual 0.2%/hr I'm used to.

  • Same for me. I bought my Forerunner 945 just 4 months ago and without any activity (and sensors, bluetooth and activity monitor deactivated) my battery down from 100% to 0% in less than 3 days. It is consuming about 1-2% per hour. I contacted Garmin Support and the suggested me to do a Hard Reset. I did it but nothing changed.

    The curious thing is that to test battery they also suggested me to deactivated sensors and start an activity with GPS. I used the Run activity and in this case it worked fine: battery lasted even more than the 18h shown in specifications. So it clearly seems a Software issue.

  • I contacted Garmin about mine last week and they asked me to do hard reset and also to plug into computer to try and force any further updates in case it Garmin had patched the software if indeed it was a software issue.  None of this worked obviously so they have now told me to send it back to be replaced for a new item as they think its the battery that's shorted and draining it.  I have explained its only started since the software update 6.20 but they don't seem to acknowledge that it's the software. It will be interesting to see what happens when my new 945 arrives and I put the 6.2 update on it. 

  • I think I can tell you already. Mine just came back replace 3 days ago and drained from 78% to 10% today with 30 min of running :( 

    I regret that I patched it after it came believing that it will solve the issue. I had 5.8 firmware so could test it for a week or soe to make sure that it is indeed software issue. 

    Anyway - Let us know how did it work for you. 

  • Have you spoke to Garmin again after you've had your replacement? If so what did they say? I really hope they sort this software out ASAP. I'm going to leave the old software on my new watch and not update until then next patch

  • Not yet, I kind of lost faith. They guy at first told me already that Polish office won't fix it and they can only replace for a new one so I don't see a point in sending it again to replace for another one. 

    I sticked to what he said originally - that they are working on a new software patch. 

    Yes! If your come with firmware older than 6.2 do not update it and let us know how does it work. 

    Any idea how to revert to previous versions?

  • Ah that's really frustrating! Hopefully soon they will sort it and will be back to normal.  I think If you hard reset the watch it reverts it back to previous software. I could be wrong though. Let me know if that works or you find another way.  Thanks Luke

  • I also contacted Garmin Support and once they realized the Hard Reset didn't solve the issue, now they suggest me to send my watch back to be replaced. I really don't know what to do because as you describe it seems it won't fix anything.

    When I did the Hard Reset i think my Forerunner already started with Software 6.20 installed, so i guess i don't have the option to downgrade it. As you all say, it's really frustrating.

  • Ye.. My F945 is also losing its battery ~10%/h after 6.20 and hard or factory reset was not help..
    In a opposite, WHR stopped working.. Tried to contact Garmin support but their first answer was how to perform hard and factory resets, but lets see what they suggest next..

    Haven't  seen any comments about WHR issues with 6.20, but what's your WHR fw version?
    Mine is 1.00.02 and I saw some reddit post from 2020, where they had version 20.xx something.

    SW 6.20 (81ed07c) | GPS 4.8 | WiFi 2.60 | CIQ 3.2.4 | BMX 1.0.2 | WHR 1.00.02 | Ant/Ble/BT 6.11 | Sensor Hub 7.02