This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Pulse Ox not working + Heart Rate not working when Pulse Ox is turned on


Got my 945 yesterday and set it up. Everything seemed to be working fine initially.

During the evening I went through some settings and turned on HRV Logging, Sleep/All-Day Pulse Ox, etc.

After this I noticed all heart rate data started displaying "--" with maybe one value every few minutes at best before going back to "--". Stress measurement started showing "Check watch fit" when trying to do a measurement and I was unable to get a single Pulse Ox reading during the whole evening. I went to sleep thinking it might just need some time to adjust.

I woke up with absolutely no sleep data or HR data for the night. After not getting more than a few blips of wrist heart rate data all morning regardless of restarts, different clock position on wrist, band tightness or even wrist side, I went back into the settings and tried turning off the Pulse Ox sensor. After this the heart rate reading updates reliably every few second and everything seems to work again.

I have now tried this multiple times to make sure. Turning on Pulse Ox in the Sensors menu makes all wrist heart rate measurements disappear and turning it off makes them work like normal again. No Pulse Ox readings have been captured at any point and can't be captured manually either.

Anyone have any info on this? Some known software issue, a faulty sensor, something else?

Software version 2.60 (2fa11e6). (EDIT: upgrading to 2.64 beta or downgrading to 2.50 does not help. Neither did 2.70.)

Lights on the back of the watch seem to work quite differently when Pulse Ox is on, cycling through a blink pattern if that is of any value, but I have nothing to compare to. (EDIT: took a video of it since it looks like the sensor in an endless reset loop: Local Garmin support said it does not look like what their test unit looks like)


  • I’ve got the same issue.

    I bought it yesterday.... 

    very disappointed 

  • Called Garmin support but sadly they had not faced this issue before and asked to send it in for repairs. Since repairs will take a few weeks I'll try to contact the seller first for an exchange.

    When Pulse Ox measurements are turned on the sensor lights repeat a pattern like this:

    To me it looks a bit like the sensor might keep resetting itself when trying to do the measurement, but I have nothing to compare to. Could someone with a working unit check what theirs looks like?

    Same thing happens if manually going to Pulse Ox screen with all-day measuring turned off. The measurement is initated and fails with sensor blinking off, after which heart rate measurements disappear for the next ~10 seconds before resuming to normal.

  • Where did you buy it from? I bought mine from Wiggle's tri bundle deal. Just asking in case it's a faulty batch.

  • I bought it in France. It’s not the bundle tri.

  • I’ve just watched the leds. It’s thé same like you.

  • I also got a response from Garmin support after sending them the same video:

    "I compared how the lights work on the video to how they do on our test device and it indeed looks like there is some kind of a fault"

    Now it would be just nice to know if it is indeed a hardware problem and if it's a bigger production run before sending the clock back and receiving an unit with the same issue...

  • On my side, no news of garmin support. Please keep me informed

  • Could you check what firmware version you have? Another topic brought to my attention that the 2.60 my watch came with has apparently not officially been released yet.

  • Hi there,

    Just bought mine in France today (tri bundle) and I have the exact same issue (no HR or stress data when Pulse Ox is on), and the same lights pattern as you...

    Firmware 2.60

    Another question: Have you tried to measure spO2 manually ? 

    If I go to the spO2 widget and try to measure it, it says "measuring" and then almost instantly "no data"...

  • Same happens for me when doing it manually.

    (The measurement actually succeeded once out of ~50 manual tries, and it took around 20 seconds. It also said "keep still" and the sensors on the back of the watch glowed a solid red. Unually they just blink and reset.)